Using 2 GX devices in one system - can one GX's control be disabled?

Dear Victron Community,

I have a Multiplus II GX which I would like to use with a CCGX system monitor.

I understand that the Multiplus II GX device is already capable of controlling the system without the CCGX, but I would like to add the CCGX to provide a display next to the Multiplus II GX, as I prefer it as opposed to the Android App and using a phone or tablet to monitor the data.

If this is possible, can either of the Multiplus II GX or the CCGX be configured to become the "master" while the 2nd GX device then becomes redundent? If possible, I would prefer to have the CCGX as the master.

The rest of the system includes 2 x Smart Solar MPPTs (non- VE CAN version) as well as a LiFePO4 battery with a BMS system which I would then connect to the CCGX.

If the simultanious use of a CCGX & Multiplus II GX (but with one's GX function disabled) is possible in one system, which communication ports should be utilized between the CCGX and Multiplus II GX? Is there a specific procedure to be followed for set-up?

Thanks


Rudi Marais asked
Rudi Marais commented ·

2 Answers

Currently available and cost-efficient USB Wifi adapter for **GX devices

It would be good to have an updated list of Wifi modules that the CCGX supports. Because the article about it on the Victron website (https://www.victronenergy.com/blog/2014/12/12/color-control-gx-accessories-tips/) is almost 3 years old and for example the ZyXel NWB2105 isn't available anymore!


I tried 3 other USB Wifi modules: 1 works, but doesn't fit in the CCGX housing (Sitecom WL-344), 1 doesn't work (Sitecom WLA-2100 v1001 > no driver support, isn't recognized), 1 sort of works, but is very slow and unstable. (Generic Nano USB)


Could someone please provide the brand/type specification of a few USB Wifi modules that work with the CCGX and that are generally available. (I am curious which USB Wifi module Victron uses in house for testing purposes at this moment.)

What would help me (and other users) mostly is the specific brand and type of USB Wifi module that 100% works well with the CCGX and is generally available at this moment in time.


I have been trying to figure out which currently available USB Wifi module is a good replacement for the ZyXel NWB2105 (antique by now), but the "buy-and-test" approach is costing me a lot of money and time, as I am down to my 3rd module that doesn't work...


If other users have good tips (with a link to the shop that sells them. I am in The Netherlands, BTW, but we should aim for a Wifi module that can be bought everywhere), that would be appreciated as well! ;-)


Thanks in advance! :-)

Dave van Dongen asked
PetarMaksimovic answered ·

9 Answers

ASUS USB-N14 WiFi dongle not working with CCGX

I purchased the dongle from a Victron rep. It works well when connected to my laptop. However the dongle power LED does not light when plugged into either USB port on the CCGX. I tried another CCGX, resulting with same no apparent dongle power. The CCGX works fine with all attached devices, and is powered by 24V from the coach battery system.

GyroGypsy asked

0 Answers

Issues updating color controller from v1 to v2

Trying to update the color controller to version 2, have followed the procedure correctly. when buttons A and B are released the screen turns blue but prepare update does not show. Ironically the controller downloaded a data file to the SD card. Also I have a brand new 150 / 100 can version regulator, the color controller will not display the data even though its in the device list. The other controllers are 150/85 older units which the data is displayed.

martysch asked
martysch answered ·

2 Answers

CCGX Ethernet Issue - Both lights on even when cable is disconnected

Hi,

I have Ethernet connection issue.

The CCGX can't make the connection finally..

Before all was good.

The situation is:

The both LED's on Ethernet connector is always ON (no difference LAN cable connected or no),

Message on the screen: Retrieving IP adr.

LAN connection is possible only via WIFI, but WIFI connection droppings accrue..

Solutions how to repair Ethernet connection will very welcome.


BR

Dalius

[image]

[image]

[image]

Dalius asked
Guy Stewart (Victron Community Manager) commented ·

3 Answers

CCGX Ethernet Issue

I have recently installed a Quattro, AC coupled to a Fronius for a complete off grid system, when it came to commissioning the ccgx could not find the fronius. After eliminating the Fronius as a problem (was discoverable on the network) looked at the ccgx and and could not find it on the network. Went to the ethernet settings and found it had generated an IP address starting with 169. Unplugged the ethernet cable from ccgx and plugged it into my laptop and internet worked fine. Then noticed the ccgx ethernet lights were still on although there was no ethernet cable plugged in, i then navigated to the ethernet menu and it said it was still connected. So i did an offline update to the ccgx, it was successful but after the reboot the ethernet lights were still on and it said it was still connected even though it was unplugged. Just wondering if anyone had a solution or any ideas?

dubzy777 asked
Dalius answered ·

2 Answers

Pylontech und CCGX

Hallo zusammen,


ich habe das Problem das mir meine 4 Pylontech Akkus nicht im CCGX angezeigt werden.


Konstellation ist:

Multiplus 2 48/5000

MPPT BlueSolar 150/30

CCGX

Solaredge SE7K


Verbunden habe ich den CCGX und die Pylontch mit dem vorgegeben Typ B Kabel von Victron.

Im CCGX habe ich dann die Geschwindigkeit des BMS auf 500kbs gestellt, also alles so wie es sein soll, aber leider werden die Pylontech nicht erkannt.


Hat jemand das selbe Problem, oder hat vielleicht eine Idee woran das liegen könnte ?


Das Kabel habe ich auch schon einmal getauscht, das sollte es nicht sein.

Die Firmware vom CCGX, MPPT (über VE direct) und das Bussystem von Multiplus (474) ist aktuell, ein umstellen auf die vorherige Firmware beim CCGX hat auch nicht zum erfolg geführt.


Bin für jeden Tip dankbar !


Grüße


Daniel asked

0 Answers

CCGX not displaying AC Loads

We have an a Quattro 5000 inverter/charger, battle born batteries and 1260 solar array. We don't see the AC input, inverter switch is showing off when it's on and no AC Loads on our CCGX display.

This is a photo below our system connected to shore power.


[image]

I have rebooted, unwired, rewired system many times with no luck.

CCGX did work at on time.


tinyarcher asked
Jwfrary answered ·

5 Answers

Use Of Solar EDGE Grid Tie Inverter and Connection s

Good day

Is there any information available with regards to connection between a CCGX Color control and a Solar Edge Grid Tie Inverter and setup info on the Solar Edge .

Regards

Johannes Cronje

Johannes Cronje asked
JohnC answered ·

1 Answer

ESS system doesn't see AC input anymore

Since a few days, my ESS system doesn't see the AC input anymore. On the screen of the CCGX the red "grid" block just has 2 stripes and no info on the AC power input, etc.
And in the VRM monitoring all the graphs relating to the AC input have flat-lined.
The system still seems to be working OK.
Only the battery is discharged to 30%, while the software limit is set to 50%.
And I have frequency oscillations up to 50.80 Hz for around an hour in the afternoon, when the PV stops producing serious power, because of shading.
Also I can not connect remotely to the CCGX Remote Control, but I am not sure that that is related.
See attached pictures.
I have already rebooted the CCGX > no difference.


[image]


[image]


[image]


Frequency oscillations on the output:

[image]

[image]

Dave van Dongen asked
Daniël Boekel (Victron Energy Staff) commented ·

2 Answers

Displaying ET112 Import/export values on CCGX in Non ESS mode

Hi I am running a Quattro in a Hub-2 configuration and want to add an ET112 between the Grid and the Quattro. For various reasons I can not run in ESS mode. I would like to display imported and exported energy on the CCGX. Is this possible at all, if so how do I configure the CCGX to do this..

jury.coetzee@gmail.com asked
Jaco Reinecke answered ·

1 Answer

Why CCGX cannot find VE.Bus?

I wonder if anyone can help me solve this riddle - I think something is broken:

Set-up: 2 x 10 kVA 48 V Quattro (2653433); CCGX (v2.54) ; 1 x SmartSolar Chargers MPPT (v1.06); 4 x BYD B-Pro 13.8kWh batteries and ESS with grid-tie enabled.

The Quattro and BYD batteries were working seamlessly together. but now they don't.

Quattro communicates with my computer but not from CCGX, sometimes works sometimes not, it confused me.

Resetting Quattro to default and reconnecting to CCGX as suggested by local distributor does not resolve the problem. Neither reconfiguring the Quattro.

The remote VEConfigure use to work but now fails during download: "

An error occurred during the downloading process.

Error Message: 'No VEBus product was found'

Error: mk2vsc-33" . I don't know what this means and have not been able to make it go away.

In desperation, I tried to re-upload the firmware. I did it without any issue.

I suspect these problems are related to one component malfunctioning most likely is the CCGX.

I would really appreciate any help.

Aydin Sadrzadeh asked
Aydin Sadrzadeh commented ·

1 Answer

CCGX no longer connects to VRM

I have a CCGX that will no longer connect to VRM. It uses an ehternet cable link between Router and CCGX .CCGX displays IP address but no Gateway or DNS values.The ethernet cable has been proved to be working. All relevant settings on CCGX have been triple checked. Firmware is stuck at 2.16 as auto update no longer p[ossible

centralwestsolar asked
Daniël Boekel (Victron Energy Staff) answered ·

1 Answer

CCGX restarts when contactor to charger switches

Update 19 June - I ended up installing a Fotek SSR-40 type solid state relay in place of the contactor, driven by the battery bank. So far so good! Unfortunately it means I'm not able to confirm any of the answers given below, though I'm sure they're right!

-----------

Please see image below for overview of the system.

The CCGX relay output is used with generator control to switch a charger based on SoC. Mains supply voltage is unreliable/variable, hence this configuration.

I've noticed often (but not always) the CCGX will restart itself when the contactor is switched off. This has been the case for perhaps 2 years now (I keep "meaning" to do something about it!).

Today, there was an apparent further progression of this problem, which I have not seen before. The system became stuck in a loop: contactor switches on -> small delay before xantrex starts charging -> ccgx trips/restarts -> contactor switches off due to ccgx turning off -> repeat.
I was able to break the loop by turning off the mains briefly until the ccgx had restarted and settled, then turing mains back on.
In this case the loads on the Multiplus where quite high 3.5kVA at the time.

Inverter/battery cables are undersized - 35sqmm (Again, something I've been meaning to rectify!).

I realise I should probably sort this out first, but I wondered if anyone might have any further ideas?

Many thanks

[image]

Colin asked
Colin edited ·

2 Answers

Warm-Up and Cool Down with Automatic Generator Start (AGS)?

I have a Color GX and a couple of Quattros. AGS works well now with my generator, but I'd like to include a warm-up and cool-down period.

For example, once the generator is started, I'd like the Quattros to wait for 5 minutes before applying a load to the generator. When the generator is going to shut down, I'd like the load to be removed 5 minutes before the generator is shut down.


Is this possible with programming? I'd like to not have to use timer relays to accomplish this and instead do with programming. Someone in a previous post mentioned the use of assistants. Thanks!

chrispendl asked
Jwfrary answered ·

4 Answers

Connecting Solar MPPT 250-85 on VE Direct

Hi,


I am working on an existing system installed with 1 x Colour Control GX, BYD batteries, 2 x Solar MPPT 250-85 charges and 1 x Inverters. Currently, the BYD batteries are connected to the Colour Control GX via CAN bus, the Solar MPPT 250-85 charger is connected on the VE Direct and inverter is connected to the controller via VE Bus


I are currently looking at augmenting the system with additional solar. There is only two VE direct port in the CCGX controller and one VE direct port on the solar charger. Is there any way I can connect the additional solar charger to the CCGX by paralleling the connection?


Thanks



xin asked
JohnC answered ·

3 Answers

CCGX USB port “black outs”

Hi all,

I have following problem.

2x150/35 MPPTs are connected to CCGX via VE direct and they work fine without problems. My 3rd 150/35 is connected to CCGX via VE direct to USB interface cable. This unit loose connection almost every day and I get an error “#67 BMS connection lost” , Device list show "MPPT not connected" and MPPT goes to “float”.

I have reset this MPPT and done reconfiguration as mentioned on manual, but no help.

I have bought and tested with second VE direct to USB cable, but no help.

I don’t use any USB hubs or USB cable extensions.

I have swapped connection between two USB ports on CCGX, but no help. WIFI is connected to the second USB port. ( I lose WIFI connection also every now and then…)

CCGX running with FW 2.53, but I have tried with FW 2.42 , but the situation is the same.

Only when I reboot the CCGX, 3rd MPPT will work fine till next CCGX reboot.


[image]


Any ideas ?

Thanks for advance !

Kimmo Paukku asked
Daniël Boekel (Victron Energy Staff) commented ·

9 Answers

How do I find CCGX MAC address?

My question is as in the title, how do I discover the MAC address of a Color Control GX unit?

I have the option to filter MAC addresses on the router I use for the CCGX-controlled system, I need to know the MAC address for the CCGX to do this correctly.

Many thanks for any advice.

glasses asked
Daniël Boekel (Victron Energy Staff) answered ·

2 Answers

Feature request: Germany 70% feed in limitation of ESS to the grid

My system: Multigrid 48/3000/35-50 with Venus GX and two connected Pylontech US2000 Plus. A BlueSolar 150/35 is DC- connected to the Multigrid. My Fronius Primo 3.0-1 is AC- connected to the output 1 of the Multigrid. The gridmeter is an ET340.

Now i want to feed in the excess energy to the grid after loading the batteries to refinance my pv- system. If i want to get my feed in energy payed i have to register my system by an electrician to the energy supplier. There is a law in Germany called EEG: Only feed in 70% of all the generators maximum power output. The electrician have to set and confirm that the maximum power feed to grid is set to 70%.

Without this limitation to 70% on the entry point to grid you have to install a radio remote controller to govern down your system in four steps by the energy supplier in case of over- energy of the grid. This controller costs about 1100€ and monthly 5€. Last choice is to cut off all inverts to 70% of power generally.

Further information see: http://www.buzer.de/gesetz/11230/a188267.htm

The technical system and measuring devices are installed, available and working fine at the ESS. Other possibilities to limitate to 70% means an huge technical effort to the whole system and money or a loss of energy.

The Fronius and BlueSolar MPPT can be governed by the CCGX to zero feed in to the grid (works fine) but there is no possibility to govern it to a adjustable max. feed in to the grid.

I need a function to set the maximum power (50W steps) feeded to the grid by the ESS.
Priorities: 1 = self consumption; 2 = loading batteries; 3 = feed to grid with adjusted maximum power
This is an important function to use this system in Germany to feed in to the grid.

I don`t know the exact conditions of the network operators but password protection for the max. feed in value will be necessary.

Is Victron planning such a function?

moeterxl asked
Ossi commented ·

7 Answers

Using the ColorControl GX in a DC-only system and UI display

I have no experience with the CCGX and would appreciate comments on this configuration.

Looking at documents on the www, it seems that the CCGX UI main display has one predetermined way of displaying the system (maybe depending on what VE.BUS device is connected) The upper part shows the AC input / output and the lower part shows the DC input / output , battery and charging/discharging plus PV inputs.
I have a non-Victron battery charger and a nonVictron inverter, which I can not connect to the CCGX. Still I want to use the CCGX to collect infos on the generated 24V (300W water turbine) and the 24V power consumed by the nonVictron 230V inverter, using 2 BMV700 with their corresponding shunts. A BMV703 will be used to monitor the battery (SOC). Also three Solar MPPTs will be connected to the CCGX. The idea is to have a central information display for the relevant parts of the system (24V) and to use the CCGX with a GSM module to connect to the Victron portal (VRM). I will use the three VE.direct sockets on the CCGX for the three BMVs. For the Solar MPPTs I will use VE.direct to USB converter cables and connect all three, through a (powered) switch to the USB socket on the CCGX. I am somewhat confused on what exactly will I be able to display on the CCGX screens. The most important question that I have, is whether I will be able to see the relevant data for all attached VE.direct devices individually, in any available menus on the CCGX (and VRM)? Is the data for the 3 Solar MPPTs shown individualy, or consolidated to a single value?Thanks.

Ciki asked
Wildebus answered ·

3 Answers

Debug CCGX Crash

I had a CCGX crash which took down a hot generator. Obviously I won't let the CCGX manually control a generator anymore, but I'd like to figure out why the CCGX crashed. I looked through the various menu settings, but could not find an error log.


Thoughts?


TylerA asked
TylerA commented ·

1 Answer

CCGX and Venus GX in the same CAN bus

HI Sirs,

Is it possible to use CCGX and Venus GX in same CAN bus ?

I have CCGX in my system, but my 3rd charge controller is connected via VE direct to USB and there is black outs every now and then. Also I would like to add temperature sensors to my setup.

So, Idea is to add Venus GX and connect 3rd charge controller to Venus via VE Direct. ( = 2 separate GX units)

For this, I guess I need battery info from Pylontech via CAN bus also for Venus GX, right ?

For monitoring I have to monitor these GX devices independently, OR use Grafana for monitor these units at the same time.


Thanks :)

Kimmo Paukku asked
WKirby answered ·

1 Answer

How to measure two DC Inputs On CCGX

I am looking to install a Victron system on my RV that will be using a third-party DC-DC charger to charge 48v house batteries from the vehicle's 12v alternator. If I were to connect this charger through a dedicated BMV battery monitor (with a second one for the system's DC loads), is there any way to have one show up as an "alternator" input on the CCGX display screen?


I know I could connect it through the BMV-700 and presumably just have the CCGX show it as power flowing from the "DC loads" box to the battery. My primary concern is ease-of-use for the end user, so I would greatly appreciate any way to configure thte CCGX for this display.

Chase Martin asked
48V on 56North answered ·

3 Answers

Can MultiPlus Compact 12/1600/70 firmware be updated through VE.Connect?

Hello everyone. I have a MultiPlus Compact 12/1600/70-16 on firmware version 154. Is this firmware out-of-date? Can this Multi's firmware be updated using VE.Connect, or do I need to use the (deprecated, dangerous(??)) VEFlash method?


Reason for wanting to update:

In addition to the Multi, the system has a BMV-702, CCGX, and 2x MPPT 100/50. The MPPTs charge a 12 volt ReLion lithium-ion battery bank from two separate solar PV arrays.

I would like to tell the MPPTs that the battery voltage is what the BMV-702 measures, and not what each MPPT senses at its "battery" output terminals.

This is because in bulk charging there is a discrepancy of as much as 0.7 V between MPPT and battery voltages, depending on charging current. Under float conditions, the discrepancy tends slowly towards 0.1 V. The voltage drop from the MPPT output terminals to the battery's terminals is presumably due to the cabling, fuses, and isolator switches, none of which can be changed.

I want the MPPT to receive battery voltage data from the BMV-702 (or maybe the Multi) to solve this problem.

I read here that I can do this with the CCGX using DVCC and SVS. However, when I tried this I got an error message saying that there is a firmware incompatibility issue. Since all firmware in the CCGX, the BMV, and MPPTs is up-to-date I conclude it must be an issue with the Multiplus' firmware.

Any help greatly appreciated!

glasses asked
glasses edited ·

1 Answer

Two GX device on same system, is this possible ?

Hello Sirs,

I can not find the clear answer... Yes or No

I have already CCGX on my system, but I would like to add second GX, Venus GX or Cerbo GX, in order to get more relay functions and also to be able to monitor ambient temperature and Air Con temperature.

I really don't want to remove CCGX out of the system, because its installed next to my setup and it is very handy.

So, is it possible to add second GX device ? :)

Thanks in advance.

Br, Kimmo

Kimmo Paukku asked
Kimmo Paukku commented ·

3 Answers

What to do when I can't add a site to Victron Portal - stuck in email loop

Hi,

I see a question about my issue but no answer on how to fix it.

It was fixed manually by the moderator.

I have my device connected to the portal and uploading data fine but when I went to add it to my list it says I have to respond to an email sent to me but I never receive the email even after many try's the same as the other post so I am stuck in a loop.

I have checked my email address in my profile and it looks ok, my user is vk3zqv@hotmail.com.

Can you please advise how to fix this issue.

Thanks

Michael

vk3zqv asked
Guy Stewart (Victron Community Manager) answered ·

1 Answer

Lost Color Control GX Power Cable

I can not find the power cable to my Victron Color Control GX. I do have a long #18-2C THHN-PVC Shielded Tray Cable...how can I use this or is there something I can buy at an eletronics store that will work?


Thankyou

I have this

https://www.wireandcableyourway.com/18-2-conductor-thhn-pvc-shielded-type-tc-tray-cable.html


railcon56 asked
Alexandra answered ·

1 Answer

Color Control Anzeigemöglichkeiten

Hallo Zusammen,

ich bin neu hier auf der Platform und habe eine Frage:

An meiner neu installierten Anlage ( Easy-Solar 2 GX / externes Color Control ) hätte ich gerne auf dem Display die aktuelle PV-Leistung angezeigt.

Geht das?

Hello everybody,

I am new here on the platform and have a question:

On my newly installed system (Easy-Solar 2 GX / external Color Control) I would have liked to see the current PV power on the display.

Is that possible?

Grüße

LayesP


                 


Layesp asked
Matthias Lange commented ·

2 Answers

Is Victron Color GX and Victron Phoenix MultiPluss 12/2000/80 incompatible?

Hi - just bought a mountain cabin with a preinstalled solar system with a Victron Phoenix MultiPluss 12/2000/80 inverter and charger, Epever 3210A MPPT charger, Honda generator with manual remote start and 2 Rolls 6A batteries.

The configuration of the Multipluss is set up so it automatically starts charging the batteries when the Honda generator is activated.

I am all new to this, so I thought it would be a good idea to buy a Victron Color GX battery status monitor. But as soon as we installed it (ethernet from Multiplus), the automation with the generator stopped working. The only way to reenable it, is to disconnect the Color GX and reload the configuration file for the Multipluss.

Any ideas why this happens? Are these devices incompatible?

Bjoern Tore Hoem asked
Bjoern Tore Hoem answered ·

5 Answers

CCGX ethernet MAC address changing (link-local)
I am attempting to use the ethernet MAC address of CCGX to determine it's IP on a DHCP network. The CCGX is running firmware v2.53.


Our device is acting as the DHCP server in this case, and the MAC address we see in the arp table for the CCGX changes back and forth between two addresses. Sometimes the MAC appears correctly, with a prefix of 'c4:f3:12' which matches the value reported on the console display and by ifconfig on the CCGX for the eth0 interface. However, sometimes we are seeing what appears to be a random address (changing on reboot), for example with a prefix of '56:e8:21'.

This second value corresponds with the MAC shown on the link-local (ll-eth0) MAC address shown by ifconfig on the CCGX. Which looks like it was added as part of this issue: https://github.com/victronenergy/venus/issues/361

My guess as to why we're seeing the other MAC is that the CCGX is sending packets out over this link-local interface, even though it has a valid DHCP IP address. Do you have any suggestions? We would ideally like to see only the 'real' eth0 MAC address once it has a DHCP IP so we can easily identify it.

Kenrick asked
mvader (Victron Energy) commented ·

2 Answers