Once you sign in you will be able to subscribe for any updates here

cerbo + ruuvi logic issue

I'm having trouble getting the temperature relay logic to work. I have a ruuvi, visible in cerbo, showing 21C right now. I'm trying to set this to trigger if the temp drops below 21C to turn on a heater. However, I cannot get that logic to work. I will want it to ultimately be, turn on relay at 2C and turn of relay at 10C. I'm using 21C now because it's room temp and it's easy to warm it up or cool it down to trigger.

For example, right now at 21C but with activation at 24C and deactivation at 39C, it's 'active'.
Activate at 25C, deactivate at 0C. this active
20 and 0, still active, 1C and 0C, still active. 1C and 1C, deactivated.
Activate at 0C deactivate at 30C, inactive. ??

Any help on this appreciated,.

dandenson asked

0 Answers

EasySolar-II GX 24/3000 with USB BT dongle for Ruuvi and Mopeka sensors


I'm trying to build a solar system around an EasySolar-II GX 24/3000 and I'd like to attach a USB Bluetooth dongle to it, like TP-LINK UB5A, or something similar.

I need this for connecting to Ruuvi temperature sensors and Mopeka tank level sensors and the internal GX module of the EasySolar does not have BT.

The ultimate goal ofcourse is to have all the information nicely available in VRM.

Anyone tried or knows if this can be done?

Thank you,


alin asked

0 Answers

Ruuvi tag and EasySolar II automation

Can you automate some things on ESII with Ruuvi sensors, like start AC OUT 2 depending on temperature (for a fan or heater), lower charging current below 5C or something similar?

jj-o-jj asked

0 Answers

Ruuvi and VRM API


I have a Ruuvi tag attached to a VenusGX. In the VRM portal I can read both temp and humidity but when I request data via VRM API I cannot find any data for the humidity. Temp is however OK.



sailon asked

0 Answers

How to Remove Old Ruuvi Tag from VRM?

I am really pleased with the the Victron support for the Ruuvi tags. I'm using them on three different installations and they are working well on each one.

I have a persistent three month old bug on one installation that I'm unable to clear up. I'm unable to remove an old Ruuvi tag that I relocated to another installation.

I've disabled the Ruuvi tag in my Cerbo GX and removed it from the device list in VRM but it is still present in the panel. I've reset Bluetooth and restarted the Cerbo GX. I'm running the latest firmware. (version 2.82-large-30). What else might be required to remove it from the VRM panel?

Thank you for your help.

antiguasky asked
antiguasky edited ·

0 Answers

Ruuvi custom widget


I have add 3 Ruuvi to my boat system. I updated their software and added a Bluetooth dongle. I can see the current temp No problem.

I then setup a custom widget graph of temp vs time. Initially it worked but no the graph is blank and says “no data”

Any advice?

phillock asked
bilgebay commented ·

0 Answers

Ruuvi tags - pressure, humidity, battery status missing from modbus

I've just added my first Ruuvi tag sensor to my Cerbo GX running 2.84. It is reporting temperature, pressure and humidity to VRM as expected. I am trying to query the data via Modbus/TCP and am only able to query the temperature. I've done some digging, and all the values are available via dbus. However via modbus, only addresses 3300-3305 are available. 3306, 3307 and 3308 all return an error.

Am I doing something wrong or have I run into a bug?

Thanks in advance.

root@victron:~# dbus -y com.victronenergy.temperature.ruuvi_c5ab96b56ce3























root@victron:~# dbus -y com.victronenergy.temperature.ruuvi_c5ab96b56ce3 /Humidity GetValue

value = 55.724998474121094

root@victron:~# dbus -y com.victronenergy.temperature.ruuvi_c5ab96b56ce3 /Pressure GetValue

value = 1019.5800170898438

root@victron:~# dbus -y com.victronenergy.temperature.ruuvi_c5ab96b56ce3 /BatteryVoltage GetValue

value = 3.1040000915527344

root@victron:~# ./ModbusCli.py -d localhost -p 502 -s 28 -r 3300


root@victron:~# ./ModbusCli.py -d localhost -p 502 -s 28 -r 3301


root@victron:~# ./ModbusCli.py -d localhost -p 502 -s 28 -r 3302


root@victron:~# ./ModbusCli.py -d localhost -p 502 -s 28 -r 3303


root@victron:~# ./ModbusCli.py -d localhost -p 502 -s 28 -r 3304


root@victron:~# ./ModbusCli.py -d localhost -p 502 -s 28 -r 3305


root@victron:~# ./ModbusCli.py -d localhost -p 502 -s 28 -r 3306

Error in function_code: 0x83 0x2

root@victron:~# ./ModbusCli.py -d localhost -p 502 -s 28 -r 3307

Error in function_code: 0x83 0x2

root@victron:~# ./ModbusCli.py -d localhost -p 502 -s 28 -r 3308

Error in function_code: 0x83 0x2

gprguy asked

0 Answers

Top Contributors - Community Supporters

Alexandra avatar image Alexandra 255 Answers & Comments
Matthias Lange - DE avatar image Matthias Lange - DE 163 Answers & Comments
netrange avatar image netrange 155 Answers & Comments
kevgermany avatar image kevgermany 150 Answers & Comments
ojack avatar image ojack 105 Answers & Comments
matt1309 avatar image matt1309 89 Answers & Comments
JohnC avatar image JohnC 88 Answers & Comments