question

joelscarr avatar image

MPPT Control “connecting”

I have the same issues as noted on several other threads. We have the MPPT 100/20 with the MPPT control. The first control ordered earlier this year showed "connecting" after a week or so of being installed and was replaced under warranty. The replacement did the same. Now the third unit, which the supplier said they updated before shipping it to me, now also simply says "connecting" after a week or so of being installed. I would be very grateful if Victron could please advise a final solution as 3 controls haven’t worked since bought new.

Thank you

MPPT - Solar Charge Controller
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

13 Answers
Guy Stewart (Victron Community Manager) avatar image
Guy Stewart (Victron Community Manager) answered ·

Hello,

If anyone is still experiencing issues with this, our apologies, we have just included additional fixes for the MPPT Control "Connecting" issues. We hope this resolves it at once and for all.

VictronConnect 5.48 (and newer) contains new firmware for both the MPPT and the MPPT Control and can be downloaded here: https://www.victronenergy.com/live/victronconnect:beta

This VictronConnect can be used to update the MPPT Control, but this requires a VE.Direct USB cable and the power supply cable supplied with the MPPT Control.

The new MPPT firmware should help to mitigate the problem and the MPPT is easier to update as it is already powered (and in case of a SmartSolar can be updated via Bluetooth).

1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

First, might I suggest that when Victron is soliciting input from users (as implied here), that this "Answer" somehow be made "sticky"? Or put at the top of the forum list? Or perhaps a new sort category, kinda like "Hot Topics," but titled "Input Needed"?


Second, the other day I flashed a buddy's Multiplus with the latest firmware, v 487.


Until the flash, his BT connectivity had been working fine. (He has both the Bluetooth dongle and the USB dongle.) But we suddenly had trouble connecting via BT after the latest firmware, in the sense that we would get a "FAILED" in Victron Connect.

We've never seen that message before.

Now, some of this problem might be Operator Error, because I had left the USB dongle connected while trying to talk the the Mulitplus via BT.

I did not know that you can't do both. (As an Enhancement, maybe Victron Connect on a smart phone could give a message like "BUSY" to tell users that the USB dongle is preventing BT Connectivity.)

So I disconnected the USB dongle. Still, we occasionally received "FAILED" Or an incorrect schematic on the Home page, incorrectly showing that the Multiplus was not receiving power from a generator.

I don't know if a firmware update on the Mutliplus affects BT Connectivity via the BT dongle. And I realize that this thread is specifically about MPPT's, not the Mulitplus.

But I mention this FAILED message in case it does.

Thiemo van Engelen (Victron Energy staff) avatar image
Thiemo van Engelen (Victron Energy staff) answered ·

Hello,

When you temporarily disconnect the MPPT control, does it stop show "connecting" and start to show the value again?

If so, can you please tell me the software version of the MPPT control? This is setting nr 20.

If it keeps showing "connecting" after the disconnecting/reconnecting, there is really a communication problem with the MPPT and all units seem to get broken after a week or so. Did you install the battery cables supplied with the MPPT control or not? This is not necessary for units that do not turn off without PV power, which is probably the case for your unit.

Kind regards,

Thiemo van Engelen


2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

joelscarr avatar image
joelscarr answered ·

Hi Thiemo van Engelen

Yes when I disconnect the control and reconnect it, it works again (ie shows a value) for another week or so. It has software version 01.02. The battery cables haven’t been installed per the instructions.

Thank you for your help.

Cheers


1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi,

It looks like this is an unknown software problem in the MPPT Control. Can you give the serial number of the MPPT? Then we can try to reproduce it here with the same model.

Kind regards,

Thiemo van Engelen


joelscarr avatar image
joelscarr answered ·

Hi

Picture attached which shows the serial number.


Thank you

f171f677-5a64-45c7-a612-0183f1d4872d.jpeg



1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi,

Can you please give the serial number of the MPPT? This allows us to determine the exact type of the MPPT and test an MPPT control with this type of MPPT.

Kind regards,

Thiemo van Engelen

joelscarr avatar image
joelscarr answered ·

Hi Thiemo


SN of MPPT attached.


Thank you

27b24f0a-bb8b-4553-9683-ba176ad97fa1.png



1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi,

Thank you. We will try to reproduce this, but it might take some time, as it also takes a couple of days for it to occur in your situation.

Kind regards,

Thiemo van Engelen

joelscarr avatar image
joelscarr answered ·

Hi Thiemo


Yes it takes a week or so. It’s happened again overnight to our Control. I look forward to hearing from you once your test is complete.

Kind regards

Joel

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

joelscarr avatar image
joelscarr answered ·

Hi Thiemo

Do you have results from your tests? It’s happened a third time to our Control over the past few weeks.


Thank you

Joel

2 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @joelscarr

Unfortunately, I do not really have any result. In the test setup here as everything just keeps working. So I have to think a bit on what to do next.

Kind regards,

Thiemo van Engelen

Hi @joelscarr

Can you perhaps save the settings of the SmartSolar and post them here in a comment?

Kind regards,

Thiemo van Engelen

joelscarr avatar image
joelscarr answered ·

Hi Thiemo @Thiemo van Engelen (Victron Energy staff)


Attached are a few screen shots. I can take others if that would assist.

Thank you

Joel


804948e4-0db5-481e-9b3e-0a018646ef67.png


2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

joelscarr avatar image
joelscarr answered ·

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

joelscarr avatar image
joelscarr answered ·

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

joelscarr avatar image
joelscarr answered ·

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thiemo van Engelen (Victron Energy staff) avatar image
Thiemo van Engelen (Victron Energy staff) answered ·

Hi @joelscarr

So after more reports and more testing we found a problem in the MPPT control that could lead to the MPPT Control getting stuck in "connecting". After finding the source or the problem, we are now in the process of releasing a new MPPT Control firmware that should fix this issue.

The error was triggered by noise on the VE.Direct lines at a specific position in the communication between the MPPT and the MPPT Control.... As this does not seem to be a wide spread problem, it looks like some installations are more likely to run into this problem. This maybe due to the VE.Direct cable being installed differently, for example running closer and longer beside a "noisy" battery or PV cable.

Kind regards,

Thiemo van Engelen

1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @Thiemo van Engelen (Victron Energy staff)


This is good progress. Thank you for the explanation. I really appreciate you looking into this for me and keeping me updated.


I look forward to the updated software.

Kind regards

Joel

Thiemo van Engelen (Victron Energy staff) avatar image
Thiemo van Engelen (Victron Energy staff) answered ·

Hi @joelscarr

Attached to this answer is the file mppt_control v1.03.xml. This is the new MPPT Control firmware. When downloading the file, the extension needs to be changed to .dup for VictronConnect to be able to use/import it.

The firmware can be updated by either of the following methods:

For both methods, it is required to use the battery cable that was supplied with the MPPT Control. In case the cable is no longer available, contact your dealer to get a (free) spare – and note that he might need to get it from Victron Repairs and this might take some time in transportation.

Kind regards,

Thiemo van Engelen


1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @Thiemo van Engelen (Victron Energy staff)


Thank you for following this through - it’s very much appreciated.


I will buy the required cable and instal the update.

Thanks again.

Joel