cpurchas avatar image
cpurchas asked

Cerbo GX Touch 50 Display information

Hello All,

I have been digging through my Cerbo GX settings trying to find a way to display data from both of my PV controllers on the main screen. I found this image online that shows exactly what I'm trying to do.... Any idea how to get this additional data to appear on the display as shown below?


cerbo gxgx device
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I'm pretty sure this is a modified UI. Take a look into the modification space.

0 Likes 0 ·

I think this question is better suited in the Modification space.
So I move it there.

0 Likes 0 ·
3 Answers
Kevin Windrem avatar image
Kevin Windrem answered ·

The image is someone's use of my "GuiMods". It provides this and other functionality such as tank and temperature info along the bottom of the screen, power gauges for AC in/out, inverter, battery. A power gauge for the PV Charger was also just added.

If you add names to your PV chargers, those names will appear where -- are in the image above.

You will also need SetupHelper for the install

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thanks Kevin, that adds exactly the functionality I was looking for... Problem is, I'm no programmer and looking at your instructions gives me a headache, I have no clue what to do. Any possibility of me hiring your expertise to make the code changes for me?

0 Likes 0 ·

I can certainly help you get this going. There is no code to write, just installing the package and running a setup script.

If the Cerbo is connected to the internet, then the easiest thing to do is enable superuser and SSH login and run a couple of commands:

wget -qO - | tar -xzf - -C /data

mv /data/GuiMods-current /data/GuiMods

wget -qO - | tar -xzf - -C /data

mv /data/SetupHelper-current /data/SetupHelper


Select install at the first prompt, then proceed to answer all the questions.

There are ways I can simplify the installation process for you but would need to collect information about your system.

My package will reinstall itself if possible but future versions of Venus OS may require repeating the installation steps.

0 Likes 0 ·

Pardon my ignorance but all I need to do is enable superuser and SSH then type in that list of commands you posted? The Cerbo is connected to the Internet full time via cellular / WIFI on my boat.

0 Likes 0 ·

Yes. And use copy/paste on the commands to make your life easier. You can copy the entire set of instructions and paste them all at once. Good luck and check back if you have problems. I'm here to help.

Instructions for root access and ssh are here:

Look into the part about ssh keys. It makes things so much easier and survives a Venus OS update.

0 Likes 0 ·

Were you able to get this going?

Let me know if you need more help.

0 Likes 0 ·

No... I haven't figured out how to enable super suer and SSH, is that done physically on the Cerbo or through the VRM panel? The system is online so hopefully I can do this remotely once I figure out how to do it. Are you able to email me at

0 Likes 0 ·

Refer to this for root access instructions:

This needs to be done through the standard GUI which you can access through VRM if it's enabled. Select Remote Console from the VRM menu.

0 Likes 0 ·

Well, I'm making slow progress.... I was able to enable SuperUser and I enabled remote support then added a root password. I then type in the address;21247 then it asks of a password. I key in the password I created and it doesn't work. Keeps asking for PW then eventually terminates session.

0 Likes 0 ·

The ssh login should be

You may also be able to use root@venus.local

If you don’t specify a user, it defaults the account on the computer you are currently logged in as.

0 Likes 0 ·

No luck. I'm using the terminal program on my mac, I connect by typing the following. It connects and asks for a PW. I type in the PW I set in the cerbo but it says its the wrong PW. I'm never asked for a username

ssh root@123.45.678.8
0 Likes 0 ·

I now have a bad situation .... NEED HELP ASAP ! I was able to finally get in and run your script. Here is my data: I'm not sure if I picked the wrong setting somewhere but now my cerbo screen is blank (all white).

Available actions:

Install and activate (i)

Uninstall (u) and restores all files to stock

Quit (q) without further action

Display setup log (s) outputs the last 100 lines of the log

Display Log (l) outputs the last 100 lines of the log

Choose an action from the list above: i

Tank enhancements are also included:

1) Bar text turns red and indicates NO RESPONSE for sensor connection errors

2) Color of bar turns red on limits

3) If space is limited, bar graph height and associated text are reduced

4) Added custom tank name

5) Added absolute quantity (e.g., gallons) next to %

6) List scrolls if all tanks don't fit

Do you wish to install the Enhanced Mobile Overview Page? (y/n): y

Do you wish to move Settings and Notifications to the top of the Device List? (y/n): y

Do you wish to hide the Tile Overview? (y/n): n

Do you wish install Flow Overview enhancements? (y/n): y

Power bar gauges require power limits be set manually

You will need to get this informaiton from the inverter's spec sheet

You also need to input the output power limit (if any) based on the master AC breaker size

These values determine the gauge's scale and background regions

Do you wish to show power gauges? (y/n): n

Do you wish set presets for AC current limit? (y/n): n

Moving Settings & Notifications to top of Device List

Hiding the Tile Overview

installing Enhanced Mobile Overview

installing System Reason Message

installing enhanced Flow overview

creating inverter power limit settings

cat: can't open '/data/setupOptions/GuiMods/inverterCautionPower': No such file or directory

power gauges not enabled

setting AC current limit presets: 10 15 20 30

setting Temperature Scale to °C

installing enhanced Tank tile

++ Package installed

restarting GUI

adding GuiMods/setup to reinstallScriptsList

creating /data/rcS.local



0 Likes 0 ·

I was able to log in again and restore to original settings so I can now see my screen. I had to press the menu button as soon as it restarted then I could access the text screens. As soon as I pressed the pages button, the screen went all white. Can you please look at the options I selected and advise what I did wrong resulting in the white screen?

0 Likes 0 ·

Just tried it again, said yes to all the options except for the show power gauges and same issue, white screen as soon as I hit the pages button. Hopefully you can assist me getting this working.

0 Likes 0 ·

Very sorry you are having problems.

The white screen indicates ONE of the screens can’t be drawn. You should be able to swipe sideways to get to the other overview pages, then you can touch the menu button to get to those screens.

The “cat: can’t open …” might be a clue. I haven’t tested installation without the power gauges since I added that code.

Try answering no to the flow overview enhancements and see if the white screen is gone. If so, then that’s the screen with issues.

Next, try answsering yes to the flow overview then answering yes to the power gauges option and enter any set of power values, eg, 1400 2000 300 3600 then 200 for the battery charging limit. If that results in curing the white screen, then go back and run setup install again and try answering no to the power gauge question.

If the flow overview isn’t the problem screen, you can try not installing the mobile overview enhancements.

Also, let me know which Venus version you are running. I know there are issues with 2.70~16 and beyond but can’t remember if I got a white screen.

The log for the GUI is /var/log/gui/current:

tail -100 /var/log/gui/current | tai64nlocal

Any errors should appear at then end of the log after switching to the problem page.

0 Likes 0 ·

Firmware version is 2.66, is that what you mean? Got that from Settings/Firmware.

0 Likes 0 ·

Yes. That rules out any firmware issues with the most recent beta firmware

0 Likes 0 ·

Tried all of the above and same issues persist.

0 Likes 0 ·

I really don't care for anything other than showing the PV amps from my two chargers on the PV icon on the screen. If you can help me to get that working it would be greatly appreciated.

0 Likes 0 ·

I need more information before I can help further. I need to know what modification is causing the problem and need to know what the error is from the log.

Run setup and select uninstall.


Run setup and select install.

Enable all options.

Swipe through all pages. If there’s a white screen, email me the log at



0 Likes 0 ·

Tried it again, accepting all the options, got a white screen, couldn't swipe, Cerbo appears frozen. Ran the command to get logs, said "permission denied" see below:

-sh: /var/log/gui/current: Permission denied


0 Likes 0 ·

Oops. To get the log:

tail /var/log/gui/current | tai64nlocal

0 Likes 0 ·

Hi Kevin, I also tried to update to this mod, I followed all of the steps which all seem to work, I did get the following:

Available actions:

Install and activate (i)

Uninstall (u) and restores all files to stock

Quit (q) without further action

I selected (i) and it seemed to do something then went back to the ssh root prompt, not sure what happened, any help is appreciated thank you.

0 Likes 0 ·
Hello Kevin. is it necessary to install the setup helper? or do I just have to proceed like the installation description in the readme file? 
Superuser is running on my device.
0 Likes 0 ·

Yes, you need SetupHelper for any of my packages and for the other packages starting to use it like the 123electric SmartBMS.

I just checked and the GuiMods ReadMe is out of date. The ReadMe also includes manual download/install instructions, but these include installing SetupHelper as well. At one point, SetupHelper and GuiMods were installed via the blind install mechanism. I eliminated GuiMods from the blind install since you get the same functionality by adding the GuiMods .tar.gz file to the same media.

The install instructions in SetupHelper detail how to install other packages on the same USB stick/SD card as used for the SetupHelper blind install.

There are two parts to SetupHelper:

First, it provides functions that all of my package setup scripts use. These functions simply the setup scripts.

Second is automatic updates from GitHub or from USB/SD media, and reinstall after a Venus update. V4.0 switched this functionality to PackageManager which is part of SetupHelper.

You can technically disable PackageManager if you only want command line based install/uninstall. But you would need to edit the SetupHelper setup script to do so.

You can disable the functionality PackageManager provides by setting automatic download and automatic install off. You'd also want to avoid inserting an SD card with any package .tar.gz files on it into the GX device.

The command line based install/unstill still works although it is not documented in the ReadMe documents. Just run the setup script one the package is manually placed in /data, e.g.,


0 Likes 0 ·
Thank you very much Kevin. 
Is there also the possibility to restore the system after a flash error or blue screen? Unfortunately I'm not a computer genius and I'm a bit scared ;)

0 Likes 0 ·
Venus OS is very robust and uses a "dual root file system" during firmware updates. Updates are written to a second root file system. If the update succeeds, the system boots from the new file system. If the update fails, the system boots from the previous file system.

As far as SetupHelper and my other packages are concerned, the blind install procedure can be repeated if problems occur there, but again this is not likely.

0 Likes 0 ·

sorry, your Downloadlink dont work

0 Likes 0 ·
jsrivet avatar image
jsrivet answered ·

@Kevin Windrem Can you go follow this link there is a bug that has been found thank you

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Should be fixed now
0 Likes 0 ·
dereppsteiner avatar image
dereppsteiner answered ·
Thank you for your work Kevin. since the past weekend the gui mod is running perfectly
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.