mvader (Victron Energy) avatar image
mvader (Victron Energy) asked

Venus OS v2.62~5 available for testing

Good day all

Just now we released v2.62~5 for field testing. Fixing various small issues.

This post is intended for all people participating in the Venus OS Beta test program.


  • Cerbo GX only: Fix bug in Remote Console on LAN password handling. This bug was introduced in version v2.57. Note that change, unfortunately breaks passwords set on versions before v2.57. To reset the password, press and hold the reset button for a minimum of four seconds. This bug only refused login on Remote Console on LAN with the password enabled, not when logging in through Remote Console on VRM. Thank you [ @JetWire ].
  • Cerbo GX only: increase buzzer volume. Thank you [@vince.farrar & @Robert Leonard].
  • Various small changes related to the VRM Portal, see below.
  • Various fixes to digital inputs handling on Venus GX and Cerbo GX, thank you [xx].:
    • Digital inputs were called GPS-es on the VRM Device Overview, no longer (fixed by changing the productids of digital inputs & pulse meters)
    • Fix missing Connection value in the gui.
    • Reset sub-settings when the input type is changed, as still seeing the previous one can be confusing.
  • Fix Remote Console on VRM & Remote Support tunnel not working when customers network included IPv4 over IPv6.
  • ModbusTCP
    • Add registers for the multiple MPP Trackers of Inverter RS and MPPT RS.
    • Add register for the VE.Bus Ignore AC Input state.
  • Fix Remote Firmware update issue when having many (for example 20 or more) VE.Can device in the network by increasing the scan time from 2 to 4 seconds.


  • Add logging of battery module status for managed batteries with multiple modules: nr of modules that are online, offline, or blocking charge or discharge, as also visible in the gui for a while already. Note that not all managed batteries support this feature and that the BYD implementation is currently being checked as it seems lime the field is not yet in line with actual mosfet status in the batteries.
  • Add logging the status of the an ESS protection that temporarily disables Feedback when the AC input frequency variation is too high. This protection has been in the ESS Assistant for a long time, and version 0x017A or newer is needed to see its status.
  • Reduce data consumption by no longer initiating a transmission when the state of a Solar charger changes, which happens often during sunrise and sunset.
  • Add logging the Ignore AC Input status for VE.Bus systemss

For changes up to an including the previous version, v2.62~4, see here:

Lastly, in the ~4 thread there is a comment about a possible regression wrt internet or VRM connectivity. If anyone else is having the same issue, please comment. I expect that we'll look into that one next week.

All the best and have a good weekend,


Venus OS
1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

hey for anyone subscribed / listening: I filled in the details. have a good Sunday

0 Likes 0 ·
2 Answers
n-dee avatar image
n-dee answered ·


Just found my house shutting down with "low battery alert" altough we are @ 25% - so I'm reverting back to nr 4

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

By the way... with both firmwares I get time synchronisation errors

0 Likes 0 ·

Hi N-Dee,

for the time sync errors: did you read the documentation about what can cause those? And do they not happen for you on v2.61? Right now I don't see any reason for a new bug that could cause that, but you testing with v2.61 can help make sure.

for the low battery alert: please check what the cause was for the alert. Low battery alert can be caused by many reasons; and happen on many devices. I'll need more information to know if its a possible new bug that needs looking into and/or delay official release of v2.62.

thanks! Matthijs

0 Likes 0 ·
n-dee avatar image n-dee mvader (Victron Energy) ♦♦ ·


Ok, so sync error is error10 and occurs only on reboot. is therefore ignorable.

Low battery alert occured "out of the blue" and i can't tell why. Battery was at 25%. The whole system tried to restart 3 times, after that I switched off all six multiplus. After reactivating the system tried to activate 2 times, then one of the fuses (on Phase 3 master blew up). I flashed back to old firmware and replaced the fuse.
System working as expected again.


0 Likes 0 ·
low-batt.jpg (134.2 KiB)


Seems as it should have been a fuse problem after all. (unstable before blown)

Didn't retest with 2.62~5 but as 2.62~7 runs "rocksolid" I assume this is no firmware issue.

0 Likes 0 ·

Hi @n-dee, good to hear; thank you for letting me know!

0 Likes 0 ·
thomasw-1 avatar image
thomasw-1 answered ·

Current beta seems to run quite smoothley on my environment.

Today I performed some tests with iobroker and Modbus. I realized that iobroker performs typcially bulk requests in case requested registers are located together or close together.

E.g. if registers 845, 846, 850 and 851 are requested, iobroker tries to load also these registers in between (847-849). GX raises an error message and rejects that request.


Would a workaround be possible that GX returns empty values for non-defined registers instead of rejecting that bulk request completely?

1608072087791.png (10.4 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Thomas, no, there is no such thing as an "empty register" in the modbus specifications, unfortunately; we discussed this internally many years ago, and conculsion was that there was no sound way to do it better than we do now.

0 Likes 0 ·
thomasw-1 avatar image thomasw-1 mvader (Victron Energy) ♦♦ ·

Thanks for your reply, Matthijs!

0 Likes 0 ·