This question was closed by mvader (Victron Energy) for the following reason: All issues raised in this thread have been closed. Further comments in a newer v2.60 testing thread please, thank you.


mvader (Victron Energy) avatar image

Venus OS v2.60~25 available to be tested

Hello all,

After the short v2.54 detour, new v2.60-beta version is now available to be tested again. See below for the changes.

In case you're new to the v2.60 beta test series, please make sure to read the previous v2.60 posts, listed below. There are several significant improvements in v2.60. The highlights are the addition of a feed-in limit, added ethernet-connected energy meters, updates on the NMEA2000-feature (addition of tanks), as well as many other improvements with regards to tank monitoring.

Change log

  • Fix “Could not connect to the MQTT server” bug in the Marine MFD App, aka Glass bridge integration. It worked well in most systems, but not when "VRM Two Way Communication" was enabled in a system without internet connection. Now, also when there is no internet, enabling that setting does not cause any issue. This bug was originally introduced in Venus OS v2.40. (also released in v2.54)
  • Fix "VRM Two-way-communication" requiring a restart in case first enabled on a new installed GX Device while there is no internet. (not included in v2.54)
  • Fix the grid-lost event from a warning to an alarm (this was broken earlier during v2.60 development)
  • Fix kWh reading errors on all MultiCompact as well as the newer MultiPlus 500/800/1200/1600 when on firmware 467 or newer.
  • Send ARP replies from the correct interface. This will not affect any normal installations; but was still wrong. Details here: Thank you Kenrick for highlighting this.
  • Improve the new grid feed-in limiter function - more improvements coming

Known issues

  • the new Ethernet-connected energy meters can't be configured; this will be fixed soon.

Best regards,

Matthijs Vader

Ps. If you don't know what this post is about: this is about our GX Product range (CCGX, Venus GX, Cerbo GX, and so forth). This message is for all the members of the Beta test group. Information on how to join (and leave) that group.

Venus OS
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

3 Answers
mbosys avatar image
mbosys answered ·

Hi mvader, just found 1 issue so far with ~25, the PV inverter is stuck on AC1 input even if it is selected to the AC output in the Energy Meter section.

This shows the issue in main graphic when grid metering is selected to external meter in ESS. (my PV inverter is connected to L2 on the EM24 if that has any effect on it)

Also have a question on this as once an external EM24 is added, the system defaults to this for all Grid values, the option of External meter or inverter/charger in ess, does this change which is used for calculations and display, as seems to be EM24 alway's?

Just wonder if there is an option like for external battery BMV, where we could choose what we use for the calculations? or can I force via dbus or MQTT which is active?


2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Mbosys

Just checked on my system which is running the latest firmware etc, mine does not get stuck as you say in the AC1 input when selected, i can happly switch between the settings with no problems to date.

Hi @mbosys, is your system on VRM, so we can have a look at that input being stuck?

For the external EM24: you can select, in the ESS menu, if the system is to use an external energy meter or not (this was improved in one of the recent official releases, first it would always use it, also if you said it should not).

You can't select which one to use though, there should be only one energy meter installed and configured to have the a Grid meter function.

mbosys avatar image mbosys mvader (Victron Energy) ♦♦ ·

Hi mvader thanks for getting back, just tried ~26 and is the same also no animated flow on the solar connection line. yes is on VRM but live system, do you need my portal ID how do I send it to you?

Hi Mark, I've sent you an email.


Checked and updated Ver 2.60.26 all running OK no issues to report.

System with 3000kw 48v mulitplus2, Pylontech 10kw pack, with Energy meters and Fronius grid tied inverter and others. raspi CCGX controller.


Rob D


slewinson avatar image
slewinson answered ·

Hi, just installed 2.60~25 and looks great.

I am trying to query the VenusGX for the water meter on DI2 and it only returns 0. The remote console displays the correct quantity.

I have seen that the modbusTCP client option is present and would love more information on it.



2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

hi @slewinson thank you. I am not sure what you mean with DI2: Device instance 2? Or digital input 2?

This water meter, is it connected to a tank input on your Venus GX? Or do you mean a water meter for which you are pulse counting using one of the digital inputs?

slewinson avatar image slewinson mvader (Victron Energy) ♦♦ ·

Hi mvader

I am using digital input 2 as pulse meter Counting for water meter.


ok thank you, we'll look into that

slewinson avatar image slewinson mvader (Victron Energy) ♦♦ ·

Thanks. Let me know if I can assist


just a note that this was closed back in june, by looking into it together (Izak) and conclusion was the issue was elsewhere - most likely in node-red application.

Jaco Reinecke avatar image
Jaco Reinecke answered ·


Not sure if this is to do with the new release, or me just being stupid, missing something.

1) 5kva Grid-tied. Max wattage set to 3kw
2) Charge amps under DVCC 60amps.
3) BMV to get SOC of the lithium batteries. (150ah x 16 cells.)
4) Daly BMS which does not integrate with Venus.
5) Inverter, BMV, MPPT firmwares are the latest.

As the SOC climbs I manually update the Minimum SOC under ESS, slowly moving it up to get to 100% SOC before a certain time, for use between 10pm - 8am.

Since I've updated to v2.60~25, the moment I now set the Minimum SOC to 100% under ESS, from SOC i.e.97%, the inverter switches off seconds later.

From then it cannot grid-tie. The moment the inverter connects to the grid (after the relay test), the inverter switches off completely.

Warnings recorded during this time:
1) Four low voltage warnings during this time. Note: Batts are full. Tested volts before and after BMS, full volts.
2) One ripple warning during this time.

After numerous attempts at changing settings, the steps to get inverter restarted:
1) Switch off breaker between inverter and DB.
2) Wait for inverter to start up again.
3) Lower the Minimum SOC under ESS from 100% to 95% on the Venus.
4) Switch on DB board breaker, standing close by waiting for grid-tie to happen.

SOC is now set at 95%, all is working, 100% SOC causing drama.


2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

ripple could be caused by the lithium batteries blocking charge, or discharge. as well as loose connections as well as other things.

we don't have any similar reports.

hope that helps; I'm afraid at the moment we can't help further.