gnagflow avatar image
gnagflow asked

Frequent disconnection of solaredge inverter with GX device

i have a multiplus 2 setup with solaredge pv inverter. The venus gx does read out the solaredge pv data via modbus TCP. I use fixed ip adresses, and the gx and the solaredge inverter are on the same switch. It works sometimes great, but often it looses the connection. I tried different things to get back the solaredge data on the venus gx, which sometimes help like: restart the gx, cut off the grid from the solaredge inverter, delete manuale the ip adress at the gx and add it again. Sometimes it works for a week and suddendly the data is again missing. Sometimes i get the pv data only for some hours or minutes. The settings on the solaredge should be right (ID etc.). I have a second install where it doesnt loose the pv inverter, only a very few times.

thank you for your help!

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

7 Answers
ee21 avatar image
ee21 answered ·

My SolarEdge was just replaced, and I can confirm both the old and new one which is CPU have this issue, even when assigned a static IP, although they are about 90% reliable and usually come back without any intervention. I think this has to do with the ModBus polling rate, something which I intend on experimenting with in the SolarEdge settings.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I have a setup with two SolarEdge inverters in combination with a VenusGX.

My older SE10K inverter with a 3.xx CPU is solid as a rock

A newer SE5K inverter with a 4.xx CPU works most of the time, but sometimes connection is lost.

@ee21 Did you already experiment with the settings on the SolarEdge inverters? Would be great if this could be fixed with some settings.

0 Likes 0 ·

Interesting I also have a setup with cpu version which is solid. My setup with cpu version switches now off every night and comes mostly back after some time in the morning. Sometimes I loose it completely. My strategy for recover: a) delete fixed IP Adress in VRM remote control and add it again. B) restart Venus Gx, c) switch off the SolarEdge system by the circuit breaker d) switch off the victron completely from the grid. E) wait a while and start from the begin.

0 Likes 0 ·

Unfortunately I have been occupied with other matters and have not played with this specifically yet. I'm trying to get the new unit to work when AC Coupled using Frequency Shifting which has been rather laborious dealing with their support agents.

I am having other issues with my VenusGX right now, which is preventing the solar from showing up in the HUD, or being calculated properly with the AC loads.. See my other thread here:

Due to this, I sort of gave up on trying to get my inverter to report data to my VenusGX, and instead have it talking to a plugin installed on my HomeSeer automation controller. This seems to work 100% reliably, as opposed to the Victron... And is using the same protocol for communication, so whatever the issue is, it seems to be with the Victron.

0 Likes 0 ·

@ee21 Have you managed to experiment with the ModBus polling rate, as I suspect you might be on to something - it's a networking or protocol issue for sure.

0 Likes 0 ·

I have not played with it still, however I did run CAT6 cable all the way to my main switch, and have not seen any disconnects recently, since then. Running 2.60 stable release also..

0 Likes 0 ·
wim-immelman avatar image
wim-immelman answered ·

I also have the exact same problem. I'm running a Cerbo GX with a Solar Edge PV Inverter on AC Output. Solare Edige is SE5000H. PV shows up after a random series of IP setting and rebooting both devices. It stays there for about a day, and the next morning it's gone again. Super frustrating, and I cannot pinpoint if the problem is with Victron or SE. Any one out there that have found a solution?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

yes, me too. SolarEdge 6k HDWave. Venus. Very frustrating, it just comes on and off. Although the SE is working fine, the client thinks it isn't on.

0 Likes 0 ·

Yip, exactly the same here. The Solar Edge portal shows there is more than enough activity on the PV side and it's cancelling out my Critical Loads as shown on the Cerbo/Venus. My best guess (today at least) is that the Solar Edge goes into some kind of "sleep" mode when it's not producing and then the Venus starts ignoring it. In my case, then Venus does not find again in the morning.

My installer believes it's a networking thing, but I've been into TCP hardware and software development for 20+ years and my network as a straight forward as it gets - all wired connections, and I've tried both (and variations of) static and dynamic IPs..

Can someone from Victron please advise as to the next steps in troubleshooting! I'm about to loose faith in one of the two suppliers, just don't know who to loose faith in :)

0 Likes 0 ·

Interestingly, I've just rebooted the Cerbo now, and now it shows up again:


This makes me lean towards the problem being on the Victron side unfortunately.

0 Likes 0 ·
1605350105573.png (58.1 KiB)

See Section 5 ?

It has a recent revision, so is maintained. If you can see something wrong I'm sure Victron would like to know.

0 Likes 0 ·

Thank you John - I have followed that section to the T and my devices are setup as such. I will double check the SE Grid Meter again today (the only one I have not checked),

0 Likes 0 ·

I have checked the SE grid meter and all is setup properly and communicating with the SE inverter.

So I am still at a loss, and I've escalated this matter to Regional head of Victron in Cape Town, but there has been no effort to rectify this.

I'm slowly becoming a very dissatisfied Victron customer (even though I've supported Victron for numerous years now and have spent a small fortune on blue boxes)

0 Likes 0 ·

@Guy Stewart (Victron Community Manager)


I have the same problem, can you help us, please

thank you

Verbindung von Multiplus II GX 48 5000 zu SolarEdge Wechselrichter geht im VRM verloren - Victron Community (

0 Likes 0 ·

Hi @raketo and @Wim Immelman

what are the VRM id's of your systems? and is it ok if a developer logs in to it?
(remote support has to be turned on for this)

0 Likes 0 ·
wim-immelman avatar image wim-immelman Daniël Boekel (Victron Energy Staff) ♦♦ ·

Yes please login and let me know how I can assist. My VRM ID is d412430b5dea

0 Likes 0 ·

1606462283395.pngThis is my picture this this morning - no PV Inverter (even though it's producing about 2.5kW) and thus it's showing no AC load or Crictical Loads. And the battery is magically charging at 1.6kW

0 Likes 0 ·
1606462283395.png (40.5 KiB)

@Daniël Boekel (Victron Energy Staff) @Guy Stewart (Victron Community Manager) Any update for us this? I'm clearly not alone in this position and my supplier is stumped as well. Please help!

0 Likes 0 ·

Hi @Wim Immelman (and @raketo)

I've just emailed you two with some extra questions.

It seems the SE inverters aren't reachable by the GX device, and now we're trying to find out why (as we don't think we've changed anything, but have to make sure)

0 Likes 0 ·
wim-immelman avatar image wim-immelman Daniël Boekel (Victron Energy Staff) ♦♦ ·

Thank you @Daniël Boekel (Victron Energy Staff). I received your email and will continue our conversation there. Appreciate the response

0 Likes 0 ·
Show more comments
hetslimmehuis avatar image
hetslimmehuis answered ·

Hi, Just reading this thread and maybe i have some options you may check. I have a 3-phase multiplus-II setup running only for 3 days now and have not that much experience yet but my first SE15k is working (connected to AC-In) and can be seen every day at the CCGX display. Hopefully I can connect a second SE3000 (single phase) to AC-Out. My SE inverters are connected by RS485 and Ethernet, RS485 is also connected to SE Smartmeter.

Following the manuals from SE regarding modbus TCP, there are two drawbacks;

  1. you can only have one Modbus connection. So if you have already connected your inverters to other monitoring sites, connections will be dropped. This is not true for SE Monitoring, because that connection is handled purely by RS485 (not Modbus).
  2. If you are having ethernet problems, this can cause the inverter to time out on Modbus and loose connection within 2 minutes. Connections can only be restarted by disabling/enabling Modbus on the inverter. Perhaps you can try this to isolate it to ethernet problems.
  3. another check you should make is where you have 2 or more inverters connected. You should have different Modbus ID’s for every device on the bus. This is not described in the Victron manuals.

If I have the same experience later, i will let you know. @Daniël Boekel (Victron Energy Staff) if you want to check it on my site, its just around the corner ;-)

following is printscreen during evening (solar is off)


kind regards,


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Daniël Boekel (Victron Energy Staff) avatar image
Daniël Boekel (Victron Energy Staff) answered ·

The issue has been found and will be fixed in a future VenusOS release.

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Is the fix added to the v2.62~7 version of the RC firmware? I still experience the frequent disconnects with this firmware version.

0 Likes 0 ·
steegergrid avatar image
steegergrid answered ·


we've also just installed a new system with 3phase Victon and have the same issues with SE hdwave 8k inverter. Very frequent disconnects.

Has the software already been fixed?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

deichel avatar image
deichel answered ·


I had the same issues last year. I can definitely say tat my VenusGX with SW V2.73 and SE7k works without disconnects.



2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

suggarman avatar image
suggarman answered ·

Is there any other device like smarthome or wallbox thats reads out the solaredge? Solaredge can only manage one connection.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.