question

miya avatar image

Venus GX and multiple Smart MPPT's

Hi All

I have a Venus GX with the following attached -

- EasyPlus 1600va 12v 70a (via VE.Bus)

- Smart BMV 712 (via VE.Direct)

- Smart MPPT 100/20 (via VE.Direct)

All the above works great - no issues - awesome. But, the problems start when I start to add additional MPPT's. The Venus manual states the maximum VE.Direct devices the Venus can take is 6, and the Venus has 2 VE.Direct port and 2 USB Ports. I assume you can add a USB hub to one of the USB ports and attach additional MPPT's with a VE.Direct to USB cable.

I have one of the VE.Direct ports used by the BMV. I have the other VE.Direct port used by one MPPT. So with no spare VE.Direct ports left I have attached attach a USB Hub to one USB port and attached a GPS and another MPPT.

When I log on to VRM Portal - everything is showing. However, after some time, the Venus loses the second MPPT.

Any help welcomed - as I ideally want to have 5 MPPTs connected - but am struggling with 2 :-(.

MPPT - Solar Charge ControllerVenus GX - VGX
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
JohnC avatar image
JohnC answered ·

Hi @Miya

Perhaps first look to your usb hub. From one of the ccgx articles:

"Extending USB ports by use of a self-powered USB hub

Although the number of USB ports can be extended by using a hub, there is a limit to the amount of power that the onboard USB port can provide. When extending the number of USB ports, we recommend you always use powered USB hubs. And to minimize the chance of issues, be sure to use good-quality USB hubs." (my bold)

Might this apply to your situation?



7 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi John

Thanks for pointing me in the right direction - the USB Hub I am using is a cheap eBay job - and is not powered. So... fingers crossed... this might solve it.

Will give it a go with a good quality powered Hub.

Many thanks for your help.

Hi @Miya did getting a powered hub solve the problem?

Hi Warwick - I have it ordered - waiting for delivery. Should arrive in couple of days. I will update once I have it installed.

Hi Warwick. It's solved it ! Cheap £4 USB hub is in the bin. Better quality £30 powered USB Hub - installed - everything working ! Happy days.

Please share the model and where you bought it.

ORICO Powered USB 3.0 Hub 7-Port Data Splitter with 1m USB 3.0 Cable & 5V/2A AC Power Adapter for Mac Windows PC

https://www.amazon.co.uk/ORICO-Powered-Splitter-Adapter-Windows-Black/dp/B07RK4KL8H

Thanks JohnC - solved and sorted.