Ricardo Chavarria avatar image
Ricardo Chavarria asked

EM530 Issues after installation (Strange Voltage, High Voltage (DC) Alarm, PV Inverter Position)

Hi Everyone.

I've detailed my initial system diagram here. My system now includes an EM530, connected using RS485.

diagram.pngESS set as Grid Metering: Inverter/Charger

I'm noticing three distinct issues.

  1. My PV Inverter won't show if I set it as Position: AC Input 1, Phase: Split Phase (L1+L2) (which is how I've got it setup physically).
  2. Yesterday, I setup ESS to have Grid Metering: External Meter. When the PV Inverter started producing, there was an alarm of high DC Voltage, and the whole system shut down. I had to restart everything. Needless to say, I reverted the settings to have Grid Metering: Inverter/Charger.
  3. The Voltages reported in one of the screens of the EM530 is absurdly wrong: L1-L2: ~160V, L1-N: ~86V.

img-5886.jpegVoltages are incorrect img-5885.jpegVoltages are correct

If anyone can help figure this out, I'd appreciate it. The reason I got a Grid Meter was to have my PV inverter show up in the right spot and to be able to really measure our consumption.


- Ricardo

ESSsplit phasegrid meter
diagram.png (83.7 KiB)
img-5886.jpeg (1.5 MiB)
img-5885.jpeg (1.5 MiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
Ricardo Chavarria avatar image
Ricardo Chavarria answered ·
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

rickc avatar image
rickc answered ·

Weird voltages: The victron software keeps putting the EM530 into 3phase mode.

You can manually put the EM530 into 2p mode with the buttons, and then recheck the display that looked weird. Every time the cerbo reconnects, it will put it back to 3p mode, however.

As for the High DC voltage, that sounds like a different issue.

Are you sure the CTs are oriented correctly?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Ricardo Chavarria avatar image Ricardo Chavarria commented ·

Weird Voltages: I did notice that my meter was set to freaking annoying!! Is there a fix for this? I changed it to 2P, and of course it worked, but it was set back to 3P soon after...can anyone from Victron help here? (@Guy Stewart (Victron Community Manager), @mvader (Victron Energy), @Thierry Cortassa (Victron Energy Staff))?

I tried setting ESS back to Grid Metering: External Meter, and of course as soon as the PV inverter started producing, the same issue happened, the whole system shut down with a High DC Voltage Alarm. I even tried adding a DV Voltage limit in the DVCC menu, to no avail.

My CTs are oriented correctly, just double checked, everything looks good.

About Fronius PV Inverter not being able to be seen when set to Split Phase (L1+L2)...I think this is because it's using solarweb API instead of sunspec API...can anyone confirm?

0 Likes 0 ·
rickc avatar image rickc Ricardo Chavarria commented ·

The 3p vs 2p split-phase thing on the carlo gavazzi meters (as far as i can tell) is an annoying display glitch, and should not affect correct operation as a meter. I’ve decoded the messages to and from the EM530, and can see what information is being queried to verify. When in 2p mode, the cerbo gx knows not to display any L3 power levels which is nice.

For your other problem, I assume the Fronius is on the output of the multilpus. Are your batteries at 100% when the DC High Voltage warning occurs?

0 Likes 0 ·
Ricardo Chavarria avatar image Ricardo Chavarria rickc commented ·

Actually the Fronius is on the AC Input 1 side of the MultiPlus. Here's a diagram from VRM when I'm able to set it to Grid Metering: External Meter - at night when there's no PV production.


I've been doing some reading and apparently there's an issue with ESS, where I need to manually control it from NodeRED so it doesn't insert extra voltage above limit into the battery. For some reason, it's not respecting the BMS limits.

1 Like 1 ·
1716611331090.png (324.0 KiB)