question

section9bateau avatar image
section9bateau asked

Bug Report: VRM Portal Economic Report will only report "Today"

Early last month I had gotten my site finally working with VRM Portal (once I finally got 24/7 internet there) and I had discovered the economic report functionality. While it doesn't give as much detail as I would like (I would hope for breakdown of used energy vs. max production if grid tied and selling, since production drops when batteries are full), I was eagerly awaiting digging into the reports at the start of this month once I had more data.


I had tried to check it a week or two ago and noticed that I still could not enter or select a date range, only "today". I was guessing that maybe there was an issue with database logs or something that would be temporary, but not today I still cannot select a start date beyond "today" or the automatically filled in date of yesterday. Both clicking the left arrow and trying to click any date except yesterday does not work.


Image of the screen: https://imgur.com/a/LXAuKB8

Browsers tested: Vivaldi 2.5.1525.40 (Stable channel) (32-bit), Firefox 67.0.3 (64-bit)


VRMbug report
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

3 Answers
Teun Lassche avatar image
Teun Lassche answered ·

Hi @Section9Bateau,


That is because your system does not have the AC inputs configured (Under System Setup), due to that we cannot cannot compare your setup with the scenarios. If you setup the correct AC inputs it will start working in the coming days.

7 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

section9bateau avatar image section9bateau commented ·

That would explain it. It worked previously/early last month, and I was using it to at least get hypothetical cost comparisons based on my usage. It makes sense that it can do the comparison with a 100% self generated to 100% bought from the grid setup, though of course it is usage based, instead of max possible generation vs. usage.


Honestly, what I would really love to see is a 3rd report added, "Max hypothetical generation", that uses the voltage and amperage numbers from the MPPT controllers to determine not the power output they were actually producing, but the maximum they could have produced, had they been grid tied and selling to the grid.

Of course, it would be useful to have the option to have it both showing the limits of the installations multiplus/grid/quattro, or a checkbox to report without those limits in effect (so solar/DC side only), as well as an option to show the actual usage/drain in a self-consumption scenario, for planning storage capacity, including over several days before hitting the recharged 100% level. Combine all this data and it would become very effective for planning system scale-ups.

0 Likes 0 ·
Teun Lassche avatar image Teun Lassche ♦ section9bateau commented ·

@Section9Bateau Thanks for the input! I have made a note of your wishes for a 3rd report

0 Likes 0 ·
Warwick Bruce Chapman avatar image Warwick Bruce Chapman commented ·

@Teun Lassche (Victron Energy Staff) what do I need to configure my AC Inputs? I have AC Input 1 set to Grid on my MultiPlus II and there is no secondary AC Input.

What next so I can select dates?

0 Likes 0 ·
Teun Lassche avatar image Teun Lassche ♦ Warwick Bruce Chapman commented ·

@warwick They are configured fine. There was a bug in the VRM reports when they were used with the latest Venus OS release. A fix for this has just been released.

0 Likes 0 ·
Warwick Bruce Chapman avatar image Warwick Bruce Chapman Teun Lassche ♦ commented ·

Laka thank you!

0 Likes 0 ·
Warwick Bruce Chapman avatar image Warwick Bruce Chapman Teun Lassche ♦ commented ·

@Teun Lassche (Victron Energy Staff) still not selectable: alt text

0 Likes 0 ·
bug.png (414.0 KiB)
dunnp avatar image dunnp Teun Lassche ♦ commented ·

I am seeing the same problem - unable to select any day but today for start or end dates. I tried a different browser - same thing; date picker still broken.


Any progress with a fix?


Phil

0 Likes 0 ·
JohnC avatar image
JohnC answered ·

Hi S9B. I don't use that, so I went for a look. Worked ok for me on both ME and FF 67.0.4.

The dates won't lock in until you get rid of that calendar on your screenshot. Select the month with the l/r arrows, and you must click on the date you want on the calendar. For both start and end dates.

Is this what you can't do?



2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

section9bateau avatar image section9bateau commented ·

I cannot click the arrows (the cursor changes and the box around the arrow highlights when I hover over, but no reaction to clicking in either browser). Also you will note that in my screenshot even the first day of the month this month is greyed out and cannot be clicked/selected.

0 Likes 0 ·
JohnC avatar image JohnC ♦ section9bateau commented ·

Yeh, I see what you're getting at, and been busting my gut to find you a solution. On both FF and ME I can't reproduce what you've posted. My legit days aren't greyed, the cursor changes when hovering over a legit date, but no box highlighting occurs. But it works.

Win10 here, maybe you've something else? Happy to test more for you to try to nail it down, but I'm lost for now.. sorry.

0 Likes 0 ·
ossi avatar image
ossi answered ·

Hi,

i have the same issue here, can't select any start date, other than the current month in the drop down selection. (Chrome Version 75.0.3770.142 (Official Build) (64-bit)


The clicking on the arrow doesnt have any impact!

image.png


for system setup i selected ESS with Grid


So a comparison isn't possible, please help.


BR

Ossi



1564388834075.png (37.2 KiB)
1564388913265.png (73.1 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.