question

gwmurray avatar image
gwmurray asked

smartBMV showing wrong current

I have a smartbmv monitoring my house batteries. To charge them I have a smartsolar mppt 100/30. When the smartsolar is charging the batteries at 4.7a 13v, the smartbmv is showing 8.2a at 12.95v? I have no other chargers in the system. What could be wrong?

Smart Battery Sense
4 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Could you have the wrong type of shunt selected?

Page 30 of the manual, 65. shunt current/ 66. shunt voltage.

0 Likes 0 ·

Thanks for the fast reply. I just checked and I use the standard shunt that comes with the bmv and it's set to the defaults, 500A, 50mV.

0 Likes 0 ·

Can you post a picture of the shunt + wiring?

0 Likes 0 ·

Thanks for the fast reply. I can post a picture of the shunt wiring but will take a while as a lot of stuff needs to come out of the aft cabin to get to the battery locker. I can say that no neg leads bypass the shunt if that is what you were thinking? it's wired as per the instructions.

0 Likes 0 ·
1 Answer
boekel avatar image
boekel answered ·

The most common reason for displaying too much current is when people connect wires to the small screws on the Shunt, these screws are for connecting the circuit board, and nothing else may be connected there.

That's the reason for asking for pictures :)

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Ah, that will be it. Many thanks for your help.

0 Likes 0 ·