bschack avatar image
bschack asked

MPPT No Longer Connects to VictronConnect

I have 2 MPPT 75/15 controllers. After changing the float voltage setting of one from 13.02V to 13.10V, it has decided it no longer wants to talk to me. VictronConnect reports "No devices found" when I plug the cable into that controller. The other controller, using the same cable, is fine.

I have a small program I wrote that can communicate with the controller. It can show TEXT protocol messages, asynchronous VE.Direct messages, and allows getting and setting of registers via VE.Direct messages. The affected controller continues to send TEXT protocol messages which look correct (I should note that the controller continues to function). I also get asynchronous messages. However, any attempts to read register values with GET, change register values with SET, get device information with PING, APPVERSION and DEVICEID messages, are met with stony silence.

I tried sending a RESTART VE.Direct message, writing to the 0x0004 (Restore default) register, and disconnecting the controller from power, but it still doesn't listen to me. Does anybody have any idea what might be happening with this controller?

MPPT ControllersVE.Direct
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
bschack avatar image
bschack answered ·

Thanks for the reply. I tried disconnecting it from power, but that didn't help.

However, I have since discovered the problem - a broken pin on the VE.Direct connector on the charge controller. Presumably this is the pin that receives information from the computer, which explains why I could receive data from the controller but never send data to it.

As I said before, I have 2 controllers, but only one VE.Direct to USB dongle, so every time I need data from both controllers (like downloading history data), I have to unplug the dongle from one and plug it into the other, which has probably led to metal fatigue in the pins. I noticed early on that the plugs were pretty tight, so I've tried to minimize the number of times I plugged and unplugged the dongle. The receptacle on the controller is only surface-mounted, which I don't think is very strong, so I guess it's not surprising that, after 5 years of use, one of the pins broke. Now I have to cobble together a fix.

By the way, does anybody know if there's a way to tag a question as "solved"?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Alexandra avatar image
Alexandra answered ·


Sometimes a good power cycle fixes things.

So disconnect PV then disconnect battery wait a few minutes then power it all up again.

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

@bschack how did you change settings?
0 Likes 0 ·