mvader (Victron Energy) avatar image
mvader (Victron Energy) asked

Venus OS v2.80~36 available for testing

Good morning all, and a very good 2022 to all of you.

Just now we released v2.80~36 for testing, various changes compared to the previous test version (v2.80~33), see below for the details.

In case you don't know what this message is about, please start with reading this link, which explains the Venus OS beta program.

v2.80 summary

The version we're working on, v2.80, has various highlights: the new AC Load monitoring, the new DC metering function, and also various improvements to the HTML5 MFD App including addition of translations, added support for the Ruuvi Tag wireless temperature sensors, and since this version it adds relay control by temperature.

What to test?

Same as before: the new features I mentioned in the above summary as well basically everything:

There are several major changes in v2.80, which can each make things break in unexpected places. For those interested in the details, the changes I'm referring to here are (a) that the used Python version has been updated from 2.7 to 3, (b) the Open Embedded release was upgraded from Zeus to Dunfell, and we changed to a read-only rootfs. Also, various application level changes that reduce the CPU load per Victron device, useful when connecting many solar chargers for example, were made. That caused some regressions earlier, which are now fixed.

How to post an issue?

Preferably all issues are organised as answers to this question. One answer per issue. So first check the existing threads. If you have the same as someone else already reported, welcome to add a comment saying "me too". And preferably some more details. And in case its not listed yet, add a new Answer. Note that Answers and Comments are two different things here on community.

Lastly, please first revert to v2.73, to double check if the issue you're seeing was present there as well. Regressions require a different treatment than other issues and bugs, and one of the first things that needs doing in triaging a report is distinguishing between the two.

The plan for v2.80

We're (still) speeding up now, to make this final as soon as possible.

Change log below.

All the best and have a good 2022!

Matthijs Vader

v2.80~36 change log, comparing to v2.80~33

  • Fix the unit for the pressure (kPa -> hPa) in the gui, for the Ruuvi sensors
  • Give hidden wifi networks a name (their mac address), so that they no longer appear as empty rows in the menu
  • More Multi RS (add ModbusTCP registers, add transmission to VRM Portal)
  • Remove transmission of load averages to VRM. Those values, visible on the diagnostics page on VRM, are not used, confusing, and the D-Bus RTT time is a much better indicator of (over-)load of a GX device, hence remove them.
  • HTML5 MFD App: Fix missing Chinese font for Garmin MFDs and other MFDs that do not carry those fonts natively.
  • Ruuvis: include status info in transmission to VRM, needed to fix hanging sensors on VRM Dashboard and other places in VRM.

v2.80~33 change log, comparing to v2.80~32

  • Add relay control based on temperature. For now, the best explanation about the new feature is here: One remark: please do not post on that issue on github. Any remarks, questions and so forth can go down below in this thread on Community instead
  • Changed atmospheric pressure from kPa to hPa since thats the more common unit for that. Note that this will mess up graphs on VRM, to be fixed later - and probably means some data of past weeks will have to be deleted from the database
  • Add SOC sync and Extra battery current for Inverter RS and Multi RS.
    • SOC sync: For systems with a dedicated battery monitor, such as BMV or a Lynx Smart BMS, that SOC is auto-synced to the RS, so that the RS can use it for controlling a relay for example.
    • Extra battery current: for systems without a battery monitor but with Solar chargers, the current as reported by the solar chargers it synced to the Inverter RS or Multi RS, where they'll use it for their SOC calculations.

Changes between v2.80~29 and v2.80~32

  • Further complete the support for the Multi RS. In more detail, a page in the UI has been added
  • Change how Shared Voltage Sense, Shared Current Sense and Shared Temperature Sense are transmitted out on VE.Can; note that this still needs further improvements, coming in the next v2.80 update.
  • Inverter RS: Add showing an error - if there is an error
  • Reduce CPU load induced by Fronius, SMA and other PV Inverters.
  • Fix bug where Shared Temperature Sense (STS) did not work between an analog temperature sensor connected directly to a GX Device and VE.Can-connected chargers such as MPPTs. This bug has been in the system since its introduction, approx v2.40, and does not affect any other combinations.
  • Add various data to allow the details in the Generator block on VRM Dashboard. See one of the slides in here and then the orange star.
  • Add transmission to VRM of humidity % as well as barometric pressure of the wireless Ruuvi sensors.

Developers, ModbusTCP, Node-RED, MQTT:

  • Note that, throughout various v2.80 beta versions, we removed the Pv/Current path aka register from our internal databus. Going forward, to use that, you need to calculate it by dividing the power by the voltage.

Various fixes for regressions introduced earlier in v2.80 development:

  • Fix poor wifi performance that either in some or all cases occurred when enabling Bluetooth connection to the wireless temperature sensors. Introduced earlier during v2.80 development
  • Fix bug in NMEA2000-out. The PV array current (Amps) was no longer transmitted. Bug was introduced earlier during v2.80 development.
  • Fix issue in Generator Start/Stop. Bug was introduced earlier in v2.80 development. Thank you @Kevin Windrem and @Elimac for reporting.
  • Fix bug where data flow from VE.Can connected devices could get stuck after a connection issue. Bug introduced earlier during v2.80.

Changes between v2.80~24 and v2.80~29:

  • Support SmartShunt DC Energy meters configured as "DC System". Two things happen when one or more SmartShunts are configured as such: (1) the power shown in the DC system box is the sum of powers reported by all SmartShunts configured as such. Allowing multiple meters is done to accommodate for example a catamaran, then you can measure the DC Systems on Port side and on Starboard side. Use the Custom name setting to give each of the meters configured as DC System their own name. (2) the DC System Current is being compensated for when setting DVCC charge current limits to Multis, Quattros and Solar Chargers. Which in more detail mains that for example when a load of 50A is being measured, and CCL by the battery is 25A, the limit given to the Multis & Solar Chargers is 75A.

    And the notes: (A) instead of a SmartShunt, also a BMV-712 can be used. (B) Setting it to be a DC System is done in the settings of the BMV/SmartShunt itself.

  • VRM Portal Connection: prepare for more details on Generator box on the VRM Dashboard.

  • Reduce CPU load. By making various changes, all relating how the different software components exchange their data, the CPU load is reduced. Note that by how much this is reduced, and if and how this changes the maximum number of connectable devices is not yet known, we still need to measure that in detail.

  • Fix broken status updates during VE.Bus (Multi/Quattro) firmware updates

  • Fix missing "Recharge" text in ESS BatteryLife state field. It said "Uknown" since Venus OS v2.20.

  • Fix Garmin MFD issue that appeared in a certain start-up sequence, this issue most likely existed in the design since the beginning.

  • NMEA2000-out: fix Solar sender DC instance storage to non-volatile memory. This never worked right, until now.

  • Fix support for Multi firmware versions prior to version 153. This was broken in v2.80~2.

  • Some more VE.Bus protocol related stability improvement, mostly affecting quite specific systems or circumstances.

  • Update recognition of Fimer grid-tie PV Inverters: Fimer recently acquired ABB and is now updating the names and recognition strings in the code.

Previous changelogs:

Complete v2.80 change log, compared to v2.73:

(still..) no time for that now, I'll make that later.

Venus OS
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Happy New Year - this is very exciting - do we have an anticipated release date for 2022 - I have 4 Ruuvi Tags ready to display - but as a user only (no technical knowledge) I am reluctant to upgrade to the Beta Firmware...but anxiously waiting for the new release

0 Likes 0 ·
hi, real good: you should be reluctant. I often see it the other way around :).

A few more weeks max is the plan. But I've now been too optimistic around v2.80 for a long time, so a bit hesitant to give dates.

0 Likes 0 ·


Anyone else having this issue “key_not_found”

0 Likes 0 ·
YES I saw it for over one hour yestreday then went away on its own - Using a venus GX on 2.73 so may be not beta related
0 Likes 0 ·
Hi, thats a VRM Portal issue. Those keys relate to translations. If anyone still has issues, please make a new post.

Afaik, there is an issue solved that could lead to this.

0 Likes 0 ·
Mark avatar image Mark mvader (Victron Energy) ♦♦ ·


Still an issue.

0 Likes 0 ·
16 Answers
Stefanie avatar image
Stefanie answered ·

  • Ruuvis: include status info in transmission to VRM, needed to fix hanging sensors on VRM Dashboard and other places in VRM.

The hanging sensor still show on VRM Dashboard. Unit in the GUI is now hPa, on VRM still kPa.


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Stefanie, right. We still need to actually fix it in VRM. You'll see it getting fixed soon.
0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ mvader (Victron Energy) ♦♦ ·
hPa / kPa is solved now. Thanks again Stefanie for pointing out that hPa is better for this.
0 Likes 0 ·
seb71 avatar image
seb71 answered ·

The Remote Console (via LAN) hotkeys are messed up (more precisely, the arrow-left button is not properly aligned and has no arrow on it, but it still works) after I updated to v2.80~36 (from v2.80~33):


Used browser: Firefox 95.0.2


Now the hotkeys are displayed properly.

I don't know why. I did not changed anything. No reboot or anything else.


1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

strange, I'll for now forget it; it will come back if need be. thank you seb!
0 Likes 0 ·
info-6 avatar image
info-6 answered ·

AC-loads is not been shown on VRM anymore. On CERBO it's all fine but VRM shows nothing

acload-cerbo.pngsetting-cerbo.pngac-load-vrm.pngImage Caption

acload-cerbo.png (39.7 KiB)
setting-cerbo.png (21.1 KiB)
ac-load-vrm.png (46.1 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.,

it's showing for me on VRM, but I remember I had to reload the page once.


0 Likes 0 ·
info-6 avatar image info-6 Stefanie ♦♦ ·

Thanks for this hint, Stefanie, but still the same... :-(

I have gone back 2 weeks and it seems that this was the case with v280~33 already, i.e. last record was on 28th Dec....

0 Likes 0 ·

Hi info-6, you are using an AC meter to measure your AC loads, right?

Not simply a Victron inverter/charger thats supplying power to the AC loads, which is for most here a bit more common.

Are you sure that this ever worked on VRM? I need to check internally, but if I recall correctly, the overviews, both on the GX device itself and on VRM, don't support using a load meter; yet. And might also be a while before we do, main use case for now for supporting AC meters in v2.80 is to measure loads is submetering.

0 Likes 0 ·
info-6 avatar image info-6 mvader (Victron Energy) ♦♦ ·

Thanks for that hint with "AC-meter"..., which was wrongly configured by me :-(

I changed now to Gridmeter and... it shows up again.

(No clue, when and why I changed that settings :-( )

As the solution is very often very simple: "Change operator"

0 Likes 0 ·
No problem, thanks for confirming!
0 Likes 0 ·
vward avatar image
vward answered ·

Is this screen right?

L1 shows 222.1V x 14.3A which should equal 3.175kW, not 1.275 kW? And Battery charging value is 2.048 kW which exceeds the Generator value?

Previously VRM was not using beta firmware and yet the Dashboard has shown these strange kinds of generator and battery charging values since the system was installed in August. We were advised by distributor to try the beta. Started with v2.80~24 and just upgraded to v2.80~36, but generator values (as below) still seem very odd/wrong.

Small home, 100% off grid installation.

9.7kW of solar and a large lead acid battery bank.

2x MPPT’s

2x 5kVA Multiplus II in parallel

Color Control GX

SmartShunt Battery monitor - we feel fairly confident we have pretty good parameters set in here, ie used the Peukert calculator, etc.

VE configure settings for both master and non-master Multiplus II:

AC input current limit - 7.3 amps (in each multi), override by remote unticked (VRM showing 14.5 in current limit)

Dynamic Current Limiting ticked

Power Assist - ticked

UPS - unticked

Weak AC - ticked

Grateful for any explanation.




easterdown.jpg (124.1 KiB)
easterdown1.jpg (243.8 KiB)
easterdown2.jpg (231.2 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi, in those MultiPlus-IIs, there is a small “audio socket”. Can you try powering them down first (!), and then briefly insert a small jack plug there, in out a few times, in each of them?

It is a bit of a guess, but what could be the reason is that that that socket is making a bad contact, and that could make the AC-in (in your case generator) current reading be wrong. Which would also explain the rest.

Please let me know the result, thanks!

0 Likes 0 ·
vward avatar image vward mvader (Victron Energy) ♦♦ ·

Thanks so much for this. There isn't anything connected into that socket, because we're off grid. Do you still want us to try this? And if so, do you want us to try this just on the master, or the slave as well?

0 Likes 0 ·
Hi @VWard , yes, please do. Both units. Hope it helps, please let me know the result.
0 Likes 0 ·
vward avatar image vward mvader (Victron Energy) ♦♦ ·

Well! Inserting an audio jack three times in each Multiplus II (powered down) and jiggling it a bit each time has made a HUGE and UNEXPECTED difference.

Can you explain why?

While the values are nearly normal looking:

  1. The values on the Dashboard still don’t add up - see below
  2. While we were running the generator the value for the Hours of AC in (VE bus summary Advanced Widget) was wrong. It was correct two days ago - before the audio jack jiggle. But 12 hours later it has updated and is correct.
  3. We now have real looking Dashboard values for AC Loads. But they still don't add up. See below

Example of point 2 (above). This was after 15 minutes, Hours of AC in is wrong:


Examples of Incorrect Values -

This relates to point 1 above

L1 230v x 14.3A = 3289 w. Which is close to what we set in VE configure and the VRM. But this does not equal 2454 W. Nor does it equal 2454 w - 2056 w (Charging Batteries) or any combination of the values on the screen. And -11 w from PV makes no sense either?


Example 2. This relates to points 1 and 3 above

We put on a known load, the Dishwasher. Previously (before AC Jack Jiggle) values for AC loads were either 0 or negative, so this is better, but still not correct:



With Dishwasher done and put on Microwave:


Thank you.

0 Likes 0 ·
1641978688878.png (342.6 KiB)
1641979013179.png (219.4 KiB)
1641979039507.png (192.7 KiB)
1641979083299.png (204.4 KiB)
1641979169887.png (203.5 KiB)
raymiller avatar image
raymiller answered ·
On Venus OS version 2.73 On the VRM dashboard display, I have the location of my Fronius Grid Inverter Galvo 2.0 (single-phase) showing up on MulitPlus II Output when the setup of the Cerbo is configured to be on the Position menu MultiPlusII  AC Input 1 (where it is installed).  Has this been addressed in 2.8x?  The Fronius Galvo 2.0 is connected via the wifi network to the Cerbo. 

In the below Dashboard display as you can see the MultiPlus is in the inverting mode and supplying the load with the PV inverter power showing up as a load instead of a Grid export.

(The other confusing issue which seems to not be related to the PV inverter, is that I have two ET340 (3phase) energy meters address #1 AC Input and #2 AC loads installed as shown on the dashboard.)


dashboard.png (264.5 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

raymiller avatar image
raymiller answered ·

Venus OS 2.73 Pylontech UP2500 (24V) battery (new 2021), Remote console, Pylontech Battery, Details menu.


The image shows two problems;

1. the Lowest and Highest cell voltage readings are reversed, this reversal also applies to the data which VRM stores on the cloud and the UI on the advanced graphing of max& min cell voltages.

2. the reported cell temperatures are being reported wrongly and again reversed (as with the voltage) when translated to the correct real temperatures.

a) the temperature is incrementing in 10C steps, not 1 degree

b) the correct temperature readings as far as I can tell should be 27C = 7C (reported), 28C = 17C (reported)

I can download the correct data directly from the battery using Pylontech Battery View software, it would just seem that Venus OS is not displaying the correct cell temperature data as downloaded from the battery BMS RS485 bus, all the other readings seems to be correct i.e. battery voltage, current and charge/discharge limits. It is really disturbing to see in winter when it is 12C readings of -150C!

How this helps to get to correct the issue, keep up the great work.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Are you sure this isn't a BMS firmware issue?

I can't see any issues with a different (non-pylon) BMS.

0 Likes 0 ·
hi both, thank you for the report. We'll look into this together with Pylon.
0 Likes 0 ·

It seems to me to be a reading of the data/display error by Victron OS as the data is available on the Pylonthech rs232 console without error. I do not know if the various Pylontech battery models are the same either. I presume that the BMS data is polled which means both the question and answer need to be aligned and in the correct format to make any sense. It is not easy coding to make sure everything is 100% correct, even very minor errors turn everything into meaningless garbage.

So Victron Energy, keep up the good work in delivering an amazing product.

0 Likes 0 ·
Hi, just to confirm: this is something in the Pylontech firmware, they'll work on it.
0 Likes 0 ·
raymiller avatar image raymiller mvader (Victron Energy) ♦♦ ·
Thanks, I'll lookout for a firmware upgrade.
0 Likes 0 ·
Al avatar image
Al answered ·

Ruuvi tags working well with GuiMods on v2.80~36

I found I can only have one bluetooth dongle at a time connected to the CCGX, and have to reboot to change dongles. Is it possible to allow two bluetooth dongles to be connected at once? This would allow me to monitor temperatures at both ends of our 38m Spits, the battery chest tag doesn't reach if I place it that far away at the moment :(


I did find the CCGX rebooted itself twice yesterday, but I've not seen it happen today, and that could also be related to my GuiMods install, I'll update if it happens again.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Al, only one dongle works at a time. For overcoming range issues, we’re currently looking at another sensor: Shelly wifi sensor.

I’ll keep the whish to work with multiple ble dongles in mind, thank you for the suggestion.

0 Likes 0 ·
@Al Question, what is your intention with the sensor at the battery chest? Will you create an alarm via VRM?

Don't you need 2 sensors than, one for each battery (in a 24V system)?


0 Likes 0 ·
Hi @Harold, I just want to see the temperature of the 'battery chest' which houses the battery bank (2v Cells), Quattro, MPPT's, crane hydraulics and switchgear etc. I already have Smartshunt and midpoint sense, and the battery temperature sensor from the Quattro, with a bilge blower fan to cool the batteries / chest, triggered by assistants using the quattro aux relay out, but I don't know the ambient temperature of the chest.

It's more important for hot summer days, as I can turn up the fan manually, but If I had the Ruuvi in there I can set a high temperature alarm in VRM to warn me, or at least just keep a track. Only need one Ruuvi for triggering a high and low temp alarms in VRM. - The battery chest is 30m away from the engine room and it's a steel boat, so wifi reception on a single dongle can't do Ruuvi's at both ends.
0 Likes 0 ·

Clear, sounds good to me ;-).

Personally I want to add an alarm, as I found out the Victron Temp sensor to the system will only adjust the charging algorithm and does not stop when overheating due to a defective cell or so!

0 Likes 0 ·
Hi Al , May be unrelated but simple question - Which is the display configuration you are using to get soe much info on the screen
0 Likes 0 ·
Al avatar image Al Anil Ghatikar ·

Hey @Anil Ghatikar I am running V2.80~38 for the Ruuvi temperature sensors and GuiMods by Kevin Windrem, which adds a few extra features including the temperatures to display on the flow overview screen.

Link to GuiMods info:

0 Likes 0 ·
stevomyatt avatar image
stevomyatt answered ·


I have a new Cerbo GX (v2.73). Bluetooth stopped working after 2 weeks so I did a factory reset using a USB today. This fixed the bluetooth. I then immediately upgraded to v2.80~36 and the bluetooth stopped working again. I did a factory reset on new firmware but still no bluetooth (blue light remains off even though it is enabled in settings). I reverted back to v2.73 and v2.72 with factory resets but still no bluetooth. In bluetooth settings the pincode remains blank and I cannot input a number. Refer attached.

Could going to v2.80~36 cause the bluetooth to stop working for good? Any advice would be appreciated!

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @stevomyatt , I checked your system, and seems to work well now - right? Did you have any other issues?

I could take a further look, to see if there is something to see - but then you'd need to enable Remote Support to allow me to login. Please let me know, thank you.

0 Likes 0 ·
stevomyatt avatar image stevomyatt mvader (Victron Energy) ♦♦ ·

Hi @mvader (Victron Energy) , thank you for checking. I have been able to reproduce the issue with the BT - If I power down the Cerbo for an extended period (first it was 2 days, then a second time was 4 hours), when it is powered back up the BT works. However, if the Cerbo resets or a short power cycle, BT no longer works (but is still enabled in settings). I have just now done a software reset on the Cerbo and now the BT is no longer working. I have enabled remote support if you would be able to have a look?

I'll also add, in the process of rolling forward and back firmware, and factory resets, the MPPT and GX Tank VRM instance has changed, the devices are now duplicated in VRM. Is there a way I can force the devices back to the original VRM instance in order to not lose history?

Regards, Steve

0 Likes 0 ·

Hi again, @stevomyatt , we'd like to swap the unit and get yours in our lab. There is something strange going on, which we don't see on other units (except one other) and impossible to further diagnose on a distance. I'll get our Service dept. to reach out to you by email to arrange it; hope thats ok for you! thank you for reporting, this helps making a better product, Matthijs

0 Likes 0 ·
stevomyatt avatar image stevomyatt mvader (Victron Energy) ♦♦ ·
Hi @mvader (Victron Energy) , yes that's perfectly fine and appreciated! Really value yours and the teams support. I am super happy with my new off grid system, happy to help. Will keep an eye out for an email.
0 Likes 0 ·
Anil Ghatikar avatar image Anil Ghatikar mvader (Victron Energy) ♦♦ ·

@mvader (Victron Energy) - I have the exact same issue New installation ( 17th JAN) cerebro - VRM ID -48e7da86fae7 . I noticed the problem after trying to enable Ruuvi tags - The Bluetooth was not used during commissioning so I don't know if worked before .

1. The bluetooth LED is off does not show any status

2. in settings Bluetooth is on and I can set pin but no ruvi tags visible- I have tow Pro and normal which work with my ipad, android phone etc.

the remote support is enabled if you want to have a look

-1 Like -1 ·
greg-johnson avatar image
greg-johnson answered ·

I'm trying the temperature-controlled relay functionality, and have a battery post sensor, as well as two Ruuvi's (which are AWESOME!). However, after having specified 'Temperature' as the control for relay 1 on my Cerbo GX, I go to the 'Temperature' menu, but am presented with a blank screen:


The sensors are visible at the top level menu, and also on VRM, so perhaps this is a bug/regression?

1642121417108.png (84.4 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I might be confused. I found the Ruuvi's also listed at the top level, and when I went into their settings, I found entries that look like 'the opposite perspective' in terms of being able to configure a relay. However, the UI (VRM remote console via LTE) was so appalling slow, and eventually hung:


I gave up. I'll try again later. Sorry if this is not a useful 'answer'...!

0 Likes 0 ·
1642122528674.png (144.4 KiB)
Ahh, it seems the two parts of the UI took a while (minutes?) to become in sync with each other. Now the behaviour (you can adjust the relay behaviour from the sensor, AND you can select the sensor from the relay settings) makes much more sense.

Finally, however, I spent the evening in my van (-10°C) and decided I don't understand the 'activation value' and 'deactivation value' settings. I can't tell if the assumption is that this relay is controlling a heater, a cooler, or something else.

For example, should the relay be activated if (AV=activation value, DV = deactivation value, T=temperature):

AV<DV<T = ???
DV<AV<T = ???
AV<T<DV = ???
DV<T<AV = ???
T<AV<DV = ???
T<DV<AV = ???

I think that is the six permissible states - but in experimenting with chilly fingers, I could not deduce what was happening. Pity the relay wasn't actually attached to a heater, really!

I had a look at other documentation for things like the tank pump behaviour, but couldn't detect a similar situation that would help me decipher my little mystery. Any tips? I'm a bear of very little brain...

0 Likes 0 ·
Hi, we improved the user interface for setting up the “temperature relay control”. You’ll see that soon in a new beta, and will answer most or all of your questions. Please await that, and when then still not clear please do post again! It helps us a lot, thanks
0 Likes 0 ·
greg-johnson avatar image greg-johnson mvader (Victron Energy) ♦♦ ·
Thanks @mvader (Victron Energy) - will do
0 Likes 0 ·
Al avatar image
Al answered ·

I seem to notice an irregularity between VRM power consumption in the overview vs what the advanced battery and AC output graphs are showing, I think the advanced graphs are correct but the overview is higher, for instance last night between 4am-5am the lowest discharge was 280W (so average was less) but the overview shows almost double at 0.50kWh. With my total consumption for Today; midnight until now, 5.6kWh which is a lot more than normal / expected.




power-overview.jpg (59.2 KiB)
power.jpg (75.9 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

hi, we're looking into this, discussed in the ~38 thread.

0 Likes 0 ·
Al avatar image Al mvader (Victron Energy) ♦♦ ·
Great, thanks for update, I'll keep an eye on the ~38 thread.
0 Likes 0 ·
Sarah avatar image
Sarah answered ·

DVCC Limit Charge Current Behaviour

Loving the new mods in 2.80~36. Not sure if this is a bug or partially implemented but when I enable DVCC Limit Charge Current setting the MPPTs go into External Control - is this the intended behaviour? Also, this also forces the MPPTs into Bulk charge mode irrespective of current. Turning Limit Charge Current off returns control to the MPPT internal algorithm. This happens irrespective of the Multiplus II being on or off. My batteries are unmanaged AGM, I do not have a BMS and there are no Assistants configured on the Multipus II. I haven't regression tested this but thought it was worth flagging as this does not match the documented management of charge algorithms when using DVCC with unmanaged batteries. SVS, STS and SCS all work as expected.


Cerbo GX, Multiplus II, 2 x MPPT VE.CAN 150/85 rev 2 (VE.Can bus), Lynx Shunt (VE.Can bus), 2 x Smart Shunt (DC Energy Meter (DC System & Alternator), 12 V 1280 AH AGM Batteries.

All firmware is up to date.



2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Sarah, thank you for the report, we're looking into this.
0 Likes 0 ·
Hi Sarah, its a bug indeed, but harmless as its only affecting the state that shown. The charger showing Ext. control is working as a slave, with the other charger being the master.

We'll fix this in the coming time, its not a v2.80 regression; and might be fixed in either the solar charger firmware or a future Venus OS version.

For in any case there is no no need to worry - and thank you for the report!

0 Likes 0 ·
Sarah avatar image Sarah mvader (Victron Energy) ♦♦ ·

bug-1-20211230.pngBug 1

bug-2-20211231.pngBug 2

Hi @mvader (Victron Energy) thanks for looking into this. Unfortunately I think there may be more than one bug. I have taken two screen shots from two consecutive days. In Bug 1 it appears as you describe. My 1A.Solar MPPT is syncing off my 1B.Solar MPPT. One is showing External Control and the other is runnning its own algorithms. You can see the MPPTs working through the charge algorithm and the respective battery voltage (1120 A/H AGM) - this I call the harmless bug. In Bug 2 both the MPPT charges are in External Control. It also appears that the MPPTs remain in Bulk charge for the whole day (Viewable on the Cerbo MPPT Daily History Page) - this is the not so harmless bug.

0 Likes 0 ·
bug-1-20211230.png (163.5 KiB)
bug-2-20211231.png (165.8 KiB)

Hi Sarah, thank you’ll; we’ll check. Is it ok if we login to your device? (Using the Remote Support system).

0 Likes 0 ·
Sarah avatar image Sarah mvader (Victron Energy) ♦♦ ·
Sure no problem. Let me now if you need anything.
0 Likes 0 ·
mauri avatar image
mauri answered ·


How to remove Ruuvi tags?

I changed some of my Ruuvi tags from 3 in one to 4 in one models. The new ones work excellently and values: Temp, Humidity & Air Pressure are visible in VRM.

Removed Ruuvi tags are also visible in VRM and I don't know how to remove them.

I first deactivated Ruuvi tags to be removed in Cerbo IO settings and then powered them off, this removed them comletely from Cerbo's display screens. But not from VRM, removed devices are also not visible in "Device list" in VRM so they can't be removed via that.

Removed sensors are still listed in Dashboard and selectable from Advanced view.

By the way, it would be good functionality to be able to select which temp sensors are visible in the dasboard, for example I have quite many of them in this installation, and maybe it would be good to not have all always on the dashboard.

Now I see all 9 active sensors + 3 already removed ones with outdated data.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @mauri,

currently you cannot remove them in VRM. There is a bug in VRM that needs to be fixed. See also the answer from Victron to my question further above.

0 Likes 0 ·
mauri avatar image mauri Stefanie ♦♦ ·
Than you Stefanie for clarification.

I thought that I saw this somewhere, but could not find it. So we just need to wait for VRM fix.

0 Likes 0 ·
Hi Mauri, what happens if you restart the GX device?

Removing sensors from VRM works, but only for sensors that were added / have been active with v2.80~36. They then show up in the device list on VRM and can also be deleted there. If rebooting won’t fix it, we’ll think of something else. Matthijs

0 Likes 0 ·
mauri avatar image mauri mvader (Victron Energy) ♦♦ ·
I changed sensors and updated from v2.80~24 to v2.80~36.

I think that I changed sensors first, so removed ones were not active in v2.80~36. I should have done it in different order.. I also took old sensors out of the site to other use, so I can't activate them in v2.80~36 anymore.

I booted Cerbo several times, but it does not change the situation. Removed sensors are not in the Device list.

0 Likes 0 ·
Hi Mauri, we'll delete them in the coming days.
0 Likes 0 ·
mauri avatar image mauri mvader (Victron Energy) ♦♦ ·
Thank you!! That's great.

Do you need my installation ID, or can you find the case via e-mail registered here?

Or is that general fix applying to all?

0 Likes 0 ·
fix applying to all. for those sensors, the data is incomplete in VRM. And what we'll do is remove all ruuvi temp sensor data which is incomplete.
0 Likes 0 ·
mauri avatar image mauri mvader (Victron Energy) ♦♦ ·

Thank you!

I see that it's done now. :)

0 Likes 0 ·
Indeed! We might need to do that a few more times: I see plenty systems still running ~33 or earlier
0 Likes 0 ·
stager avatar image
stager answered ·

I burned venus-image-raspberrypi2-20220103133553-v2.80~36.rootfs.wic.gz to SD and booted a Raspberry Pi.

I opened http://venus.local/ in browser and saw:

Remote console
Failed to connect. Make sure to enable Remote
Console for LAN, and reboot the device.

What's wrong?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @Stager , I saw your post in the later thread,, and assume that means you solved this one.

0 Likes 0 ·
stager avatar image stager mvader (Victron Energy) ♦♦ ·
I installed ~38, and do not have problems.
0 Likes 0 ·
lars78 avatar image
lars78 answered ·
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

andreholgersson avatar image
andreholgersson answered ·

Just got a Carlo Gavazzi EM112, and has been trying it out as an AC Load monitor on my boat. It is placed just after the main switch, and it is measuring the total load of the water heater, a electrical stove, an auxiliary outlet, as well as a multiplus. The idea is to get a picture of the total energy of shore power used, not just what is passing through the multiplus.

Haven't seen any info of really what to expect, but here are my findings so far:

After adding the monitor, it seems to show up under Settings, Energy meters, where it cannot be renamed or removed. As of roles, AC load seems to be called "AC meter" instead of "AC load".


In the main menu, the same meter appear, this time with what seems to be correct values, and also a device menu with possibility to rename the monitor:

Under setup and role, at this instance the role is called "AC Load", not "AC meter" as in the first instance.

* I cannot find the corresponding measurements in VRM portal. Not sure if I am supposed to yet? I am hoping to be able to get the following: Voltage, Current, Watt, Hz, Ah, Wh.

I am also wishing for a optional separate square on the GX main menu with the current load for this meter.

1642790326045.png (12.4 KiB)
1642790379607.png (13.1 KiB)
1642790554237.png (17.9 KiB)
1642790592000.png (16.9 KiB)
1642790701173.png (13.1 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Anil Ghatikar avatar image
Anil Ghatikar answered ·

@mvader (Victron Energy) - posting again incase the post is lost in the thread -

Brand New Cerebro - Bluetooth not working at all - should i try the antena repositioning or you want to check remotely first

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.