czauto avatar image
czauto asked

Et340 to Venus GX connectivity issue

Hi Guys. I recently installed an ET340 Energy meter to my ESS system. I've been running ESS for quite some time without any problems and decided to compliment the system with a External energy meter about a week ago. I printed and read the instruction manual thoroughly before installing the meter. The process went without problems and the GX immediately registered and showed the meter. I left it running until the next day to make sure there was no teething problems before tidying up.

I plugged out the USB side of the cable (Genuine Victron RS485 to USB cable) and routed it through the existing trunking, as far away possible from existing power wiring. When I plugged it into the Venus GX again, there was a spark from the cable and then smoke coming from the chip side of the cable. I could clearly see that it was burnt black on the inside of the USB housing.

Seeing that a USB device normally can be plugged and unplugged while the host device is on, I didn't think that this would be any different so I thought it might have been a faulty cable.

I ordered a new one, connected it exactly the same as the other one, re-checking the manual numerous times, powered off the meter and GX device and then plugged it into the USB port. I powered everything up but do not get any communication now. The USB cable's red LED (one closer to the back) is on constantly and the red one closer to the front occasionally flashes a few times, trying to probe the meter I guess, but nothing else happens. The ET340 has got a constant green LED on and the red KWH LED flashes according to electricity usage.

The energy meter still shows up under "energy meters" in the remote console but does not register anywhere else, like when the meter would not be powered up.

I've also tried connecting to the meter with the cable and 2 separate laptops but no success. There is still no communication with the meter. I've checked and re-checked the wiring over and over again.

Can anybody maybe give me some suggestions??

Venus GX - VGXrs485
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
Matthias Lange - DE avatar image
Matthias Lange - DE answered ·

Can you make screenshots where the ET340 is shown in the remote console?

Maybe the USB controller of the Venus is fried or the RS485 controller of the ET340.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

czauto avatar image
czauto answered ·

Hi Matthias,

Sorry for only replying now but we had some flooding and was without Internet access for some time.

As I explained, the ET340 showed on the remote console and everything worked fine after installation but after I tidied up the wiring and re-inserted the USB plug of the RS485 to USB cable into the Venus GX's bottom USB port, it arced and after smoke came out of the chip side of the cable, nothing worked. I then ordered a new cable and now cannot get any communication. I don't think the problem is on the Venus's side seeing that the small red LED is still flashing every few seconds like it's trying to probe the energy meter but without any communication established. I also cannot get communication to the ET340 from two different laptops.

Attached is pictures from the remote console still showing the meter but it shows no data from the meter itself like it did before the first cable blew.

What could have caused the arc? And could it really damage the energy meter through the USB connection?? It's a brand new meter.....Capture1.PNGCapture2.PNGCapture3.PNG

capture1.png (12.7 KiB)
capture2.png (22.3 KiB)
capture3.png (23.4 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.