question

Sakkie Van Heerden avatar image

EasySolar-II GX Display "Solar: ESS"

I've installed a EasySolar-II GX 48/3000 off grid with only a generator, solar panels and a BlueNova BN52v-125amp-6,5k LI battery connected via CAN port and BMS. Communications between EasySolar and batteries seems to be fine.

On the display circle of EasySolar, it shows "Solar: ESS". What does that mean? Batery SOC is 74% but MPPT is not charging. It is cloudy, will this result in solar displaying ESS?

Ve.Connect APP shows under settings, ESS: "No ESS Assistant found" which is right because I'm off grid.

The way I understand is that ESS is a function related to the grid and not to the MPPT.

Multiplus-IIESSsolardashboard display
1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Sorry, I mean .... "display cycle", not circle...

3 Answers
JohnC avatar image
JohnC answered ·

Hi @IJvH

It used to mean what is now 'External Control', and in your case possibly between the BMS and GX/mppt. This was progressively tidied up in the firmwares as it was confusing users. Maybe you still have a remnant in firmware.

It won't hurt to leave it if all is working well, but you could try updating firmware(s) if it's annoying you.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Sakkie Van Heerden avatar image
Sakkie Van Heerden answered ·

Thanks John. My firmware is updated to the latest version 2.73. I am awaiting a replay from baterye manufacturer, think you are right, BMS and GX/mppt issue. Everything seems to be working fine, except for display not displaying real state of charge for instance: bulk, absorb or float.

10 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

@IJvH

I'm personally unfamiliar with those particular batts, but it's typical that the mppt ceases displaying it's own charge status when that is now under control of the bms. There's a little about those batts here: https://www.victronenergy.com/live/battery_compatibility:bluenova


Thanks for the response. I've read through the linked document and I think it might be the new firmware that I've loaded. Let me explain chain of events (also keep in mind, this is my first installation and I'm a ordinary farmer):

I installed 2 identical systems (not connected parallel). First I couldn't get the charger to see the BMS, only to find out that for the BlueNova batteries the RJ45 cable must be connected to the GX's VE.Can port and not the VE.Bus port. After I've corrected that, everything was fine and MPPT's was displaying the "state of charge" correctly: bulk, absorb, float etc. Then I had to make sure of charging voltages and was busy configuring the EasySolars via Ve.Connect and saw that I had 2 different firmware versions on both GX's and both were old. I tried to update it online and had to create a hotspot with my cellphone. The signal was weak and on and off all the time and before I had a proper connection, I DISABLE "Create Access point" and there you go: NO WIFI! That's when I start searching this community for answers, only to find out I made, yes, a rookie mistake. Couldn't find a solution from suppliers nor on this comunity, but it turn out to be very easily solved by just connecting via eathernet and to enable "Create Access point" again. Bear in mind that I was fairly frustrated at this point and battled my butt off to get things to connect again.

So I abandoned online update and go for usb update which work fine. At that time it was also late afternoon and sun was fading. Only the next day I realized the "display error" displaying ESS on Solar cycle. Of course I didn't though it might be because of the update, but after your discussion, I want to see if that might be the problem for BMS and MPPT communication.

Is it possible to upload a older firmware version onto my EasySolar?

Attached is a photo of display

screenshot-20211029-074545-video-player.jpgImage Caption

JohnC avatar image JohnC ♦ Sakkie Van Heerden ·

@IJvH

Farmer eh? Don't worry, you have plenty friends here.

You mentioned 2.73 earlier. That's current for the GX, but your Easy is a combo box, and also has mppt and Multiplus firmwares. Victron normally recommends updating all at installation time, so at this stage I wouldn't recommend reverting any of them to older versions.

You may well be struggling remotely with a dodgy phone link. Really great with a Win laptop and reliable web. Especially with VRM up and full GX screen available. VRM can check and update firmwares easily.. https://www.victronenergy.com/live/vrm_portal:remote-firmware-update

All the manuals you might need are available via the Victron website, and Victron Professional has the newest firmwares on call, but VRM can do it with a click.

The 'ESS' thing suggests old firmware, but that's likely closer to what you seek than the mppt showing charge states independently.

Don't get frustrated though, that won't help. Keep asking as you need, we'll keep trying..



Ok, so I got VRM set up and added one of my installations. Something I need to mention also regarding my installation: It's done in a outbuilding, with my windows laptop I can connect to my wifi, but the EasySolars don't see my wifi. On my VRM portal, I can see and select my installation, but the menu don't show firmware update. Is this because the EasySolar is not connected to my wifi?

20211029-130131.jpgscreenshot-20211029-124322-chrome.jpg

Is there any way I can get around this without internet?

JohnC avatar image JohnC ♦ Sakkie Van Heerden ·

@IJvH

It seems you have VRM up ok. Look in Device List for Firmware Update. Edit: If you decide to update the Muliplus, go to VEConfigure first and download the settings file (it's .rvsc type), or you'll lose any changes you've made in the Multi. You can upload it again later.

The second pic shows a 172.xx.. address, which will be the local Wifi Access Point. A bit different, but maybe this will explain a little (for a Cerbo, but hopefully similar). https://www.victronenergy.com/media/pg/Cerbo_GX/en/accessing-the-gx-device.html

Good you have suitable kit to access it all. You'll get there.. just gotta find your way around.

Just take care changing settings, unless you're sure you know what you're doing. :)

Ok, I've mannaged to use my phone as hotspot, connected to my wifi, and connect my EasySolars' wifi to my phone. At first it was only possible to see the "Fimware Update" in the device list of the one EasySolar. I had to reset the other GX devise in order to do the updates.

Now, both EasySolars' GX's, MPPT's and Chargers' firmware is updated, but still, display cycle shows: "Solar: ESS".

So I guess it got something to do with the BlueNova batteries' BMS that work via VE.can?

JohnC avatar image JohnC ♦ Sakkie Van Heerden ·
@IJvH

Yeh, must be a code remnant. But you know what it means now, and you've done well updating firmware. So all should be good for any fine tuning you need to do.

And oh, I was a farmer once, we adapt well.. :)

Yep, thanks for all the advice and help. I will still take it up with BlueNova.


O, and btw, I was not a farmer, but I've adapted the past 11 years hehehe, but I won't give it up for anything... cheers!

nickdb avatar image nickdb Sakkie Van Heerden ·
Could also be an old assistant that is loaded on the multi.

Did you update the multi firmware as well (what is it reporting in the device list on VRM)?

Assistants can be done via veconfigure with a mk3 usb cable.

veconfigure will get the latest versions from your laptop via the internet. You can then connect directly to the inverter VE.BUS port.

You can also download the configuration remotely from vrm (if the gx is online) and then open it with veconfigure.

It can then be applied back via vrm as well.


All this modern tech really likes to be online to make life easier.


I've updated my multi as well. All firmware is updated now. So the problem is not firmware on the victron side I think, rather communication and/BMS. Still showing:


screenshot-20211029-074545-video-player.jpg

nickdb avatar image
nickdb answered ·

You need decent signal - have you got a hotspot (such as your phone) that you could use temporarily?

If you have a ve direct to USB cable, you can connect to the mppt via the victron connect (local) app and apply the update that way as well.

You can do the same with the mobile phone app and bluetooth (if it supports bluetooth).

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi nick, yes I can set my phone as a hotspot, but cellphone signal is not stable.


I will try to connect with Bluetooth to mppt and see if if I can manage.

Another problem is, I helped my nabour farmer installing the same setup and he don't even have cellphone coverage. Once I've got mine sorted, I'll need to help him...